Topic Title: Radeon HD 4850 OpenCL driver problem
Topic Summary: Since installed Catalyst 12.6 Legacy, OpenCL doesn't work anymore
Created On: 11/16/2012 04:43 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/16/2012 04:43 AM
User is offline View Users Profile Print this message

Author Icon
pipperox
Peon

Posts: 3
Joined: 09/16/2011

GPU: Radeon HD 4850

OS: Windows 7 64bit Ultimate

CPU: Intel Core i7 860

 

Hi, all has been fine and dandy, until recently i've installed the Catalyst 12.6 driver package (the last one available for this GPU).

 

Now i have a series of issues related to OpenCL:

1) Upon startup, i get the error message: "kdbsync.exe has stopped working"

2) If i run GPU-Z, i get the error: "During previous startup GPU-Z crashed at OpenCL detection. Please update your OpenCL and graphics driver".

And then "ATI OpenCL driver bug detected, skipping OpenCL detection. Uninstall the AMD Stream SDK / OpenCL driver to re-enable this functionality."

3) If i run applications which use OpenCL (Indigo Renderer, LuxRender) they now crash on startup (they used to work fine before the driver update)

 

I've tried all reasonable operations to restore system functionality: uninstall driver, reboot, re-install, start windows in Safe Mode (cannot re-install Catalyst in safe mode because it cannot detect the HW configuration), and even deleted OpenCL.dll from C:\Windows\SysWOW64 and C:\Windows\System32 before re-installing the Catalyst package.

 

Please HELP!

 11/16/2012 10:14 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7278
Joined: 11/13/2009

http://forums.amd.com/game/messageview.cfm?catid=454&threadid=162182&enterthread=y



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

 11/17/2012 06:45 AM
User is offline View Users Profile Print this message

Author Icon
pipperox
Peon

Posts: 3
Joined: 09/16/2011

That did the trick, thanks!

Statistics
86511 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.