Topic Title: Is my four years old ATI Radeon 4870 video card dying/broken?
Topic Summary:
Created On: 12/16/2012 03:51 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/16/2012 03:51 PM
User is offline View Users Profile Print this message

Author Icon
antdude
Grinding Levels

Posts: 131
Joined: 02/12/2009

Hello.

I noticed my weird colorings and crashes with computer games with my four years old MSI R4870-T2D512 OC Radeon 4870 video card (512 MB; PCIe; DVI -> VGA).

Symptoms:
-Weird colorings (e.g., purple color weirdness in Half-Life 2's Lost Coast (HL2:LC) and redness and blackness in RO2:HoS). Crysis didn't show this.
-Black blank screen -- video signal lost (see http://i.imgur.com/gmDd6.jpg and http://i.imgur.com/C2SdO.jpg what is shown even with its weird colorings but not on my monitor due to video signal losses) and fan stop spinning for few seconds and resume. Computer/Windows still responds based on pings, ssh, telnet, cmd.exe, etc. Once, it went back to 4-bit VGA with its ati2dvag display driver stopped responding message to reboot. Other times, I can sometimes recover back to Windows if I kill processes, open up cmd.exe fullscreen, etc.
-Video card and its fan air feel almost hot (not burning) in both idle and heavy usage.

Up to 81C/177.8F degrees when gaming with HL2:LC's stress video test and Red Orchestra 2: Heroes of Stalingrad free weekend.

65C/149F degrees with a manual full 100% fan (it still works) control to blow out heat for about ten minutes in a 25C/77F degrees room.

Note: Used Google search engine form's calculator to convert temperatures.

Does this sound like my video card is broken or dying? 2D stuff seems to work fine. I did have to fix my computer's hard lock up problems when playing videos (including Flash) by downgrading back to v8.10 driver in my old, updated Windows XP Pro. SP3. You can read http://zimage.com/~ant/antfarm/about/computers.txt for my detailed primary computer specifications.

Thank you in advance.



Edited: 12/16/2012 at 10:58 PM by antdude
 12/19/2012 09:10 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

I'd try it in another computer. It can be a f*****ed up OS install, motherboard issue etc. If it takes the problems to the other machine, then it's the card itself.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 12/19/2012 09:31 PM
User is offline View Users Profile Print this message

Author Icon
antdude
Grinding Levels

Posts: 131
Joined: 02/12/2009

Originally posted by: Eydee I'd try it in another computer. It can be a f*****ed up OS install, motherboard issue etc. If it takes the problems to the other machine, then it's the card itself.

 

OK. I don't have another PC to try it in. I don't really want to reinstall from scratch unless there's a way to do with a live disc or USB drive.

Statistics
85366 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.