Topic Title: Powercolor 4850 Freezups
Topic Summary: Games stop responding
Created On: 01/21/2013 04:55 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 01/21/2013 04:55 AM
User is offline View Users Profile Print this message

Author Icon
dbimtb
Peon

Posts: 4
Joined: 01/21/2013

Ok, I purchased powercolor ATI 4850 Radeon on ebay a year ago but I have a feeling that this card is defective.

Windows 7 scoring works fine;

Heroes Of Newerth main default screen is fine (I left it running overnight);

However,

Games such as

The Saboteur at some point starts to shiver and it stops responding.

Chess Titans completely locks up pc.

 

My feel is that this card which I purchased a year ago is defective.

Now, I was looking at the catalyst control center.  GPU Clock is set at 650 Mhz and I think this card runs at 500 Mhz.  Temperature is ok.  Overdrive is checked and I am unable to uncheck it, the graphic properties are locked at this setting.

So are there any options I should enable / disable so I could possibly make this card work.

Thanks.

 01/21/2013 06:09 AM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

Try it in another computer.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 01/21/2013 05:09 PM
User is offline View Users Profile Print this message

Author Icon
dbimtb
Peon

Posts: 4
Joined: 01/21/2013

Thanks.  I did try that and there is a same issue.

I don't know if it is a particular function of the card or something else, however, what did work was to disable sound completely.  I had saboteur running for several hours and screen didn't freeze at all.

I tried a different sound card but that didn't help either.  I just gave up.

I'll just keep the card, maybe a different pc will come arround.

Statistics
88977 users are registered to the AMD Support and Game forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.