Topic Title: ATI RADEON X800 GT and MineCraft
Topic Summary: Semi-emergency
Created On: 04/21/2013 11:37 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 04/21/2013 11:37 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 5
Joined: 04/21/2013


On the advice of my room mate, and a video card rating site, I switched from an nVidia card to an ATI card.  He was getting a new one, and it was an upgrade for me (according to the rateing site).

Since I 'upgraded' to the new card, I've been having tremendous difficulty getting this card to function with Minecraft.

I am able to play other games, like league of Legends, Grand Theft Auto: San Andreas - Multi Player and Wizard101, but every time I try to run minecraft i get the following error log:

[quote]Bad video card drivers!     

Minecraft was unable to start because it failed to find an accelerated OpenGL mode.
This can usually be fixed by updating the video card drivers.

--- BEGIN ERROR REPORT 7fe0271 --------
Generated 21/04/13 11:18 AM

-- System Details --
    Minecraft Version: 1.5.1
    Operating System: Windows 7 (amd64) version 6.1
    Java Version: 1.7.0_09, Oracle Corporation
    Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
    Memory: 407282704 bytes (388 MB) / 514523136 bytes (490 MB) up to 954466304 bytes (910 MB)
    JVM Flags: 2 total; -Xms512m -Xmx1024m
    AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
    Suspicious classes: No suspicious classes found.
    IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
    LWJGL: 2.4.2
    OpenGL: ~~ERROR~~ NullPointerException: null
    Is Modded: Probably not. Jar signature remains and client brand is untouched.
    Type: Client (map_client.txt)
    Texture Pack: Default
    Profiler Position: N/A (disabled)
    Vec3 Pool Size: ~~ERROR~~ NullPointerException: null[failed to get system properties (java.lang.NullPointerException)]

org.lwjgl.LWJGLException: Pixel format not accelerated
    at org.lwjgl.opengl.WindowsPeerInfo.nChoosePixelFormat(Native Method)
    at org.lwjgl.opengl.WindowsPeerInfo.choosePixelFormat(
    at org.lwjgl.opengl.WindowsDisplay.createWindow(
    at org.lwjgl.opengl.Display.createWindow(
    at org.lwjgl.opengl.Display.create(
    at org.lwjgl.opengl.Display.create(
    at org.lwjgl.opengl.Display.create(
    at net.minecraft.client.Minecraft.a(SourceFile:235)
    at avv.a(SourceFile:56)
    at Source)
--- END ERROR REPORT fcbb7e81 ----------[/quote]

I need Minecraft to work because I'm a co-owner of a server.  My presence is required.

I have downloaded and installed Catalyst versions from 8.0 to 13.whatever, and 9.1 was suggested by another site.  All except the latest Catalyst (Which doesn't even support this card) install without fail.  All others 'stop working' after I click the Install button.
I've even gone deeper into the C:\ATI or C:\AMD folder and run the setup from the 'bin' folder ('bin64' crashes as stated above).

It doesn't matter what I do it seems to not want to work.  Here are the steps I took with the install that actually worked.
1. Remove old drivers from Microsoft found on Device Manager.
2. Run C:\AMD\AMD_Catalyst_13.3_Beta3\Setup.exe as Administrator.
3. Do a little dance when it didn't crash / stop working
4. Restart my machine.
5. Run Minecraft and hold my breath.
6. Pull out some more hair when it crashed.
7. Have a 'breath of fresh air'.
8. Come here to post the issue.

If anyone knows how to fix this, please let me know.  I'm starting to go bald...

Edited: 04/22/2013 at 09:19 AM by Smiggledoink
 04/22/2013 09:16 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 5
Joined: 04/21/2013

I understand that this is an old, obsolete card.  I figured someone would at least be able to point me in the direction of a third-party site that offers just the drivers and OpenGL files for my card.
I'll just go back to the computer recycle place I donated my nVidea card to and see if I can trade for this ATI.

Thanks anyway.

 04/22/2013 09:47 AM
User is online View Users Profile Print this message

Author Icon
80 Column Mind

Posts: 13180
Joined: 04/17/2008

Or you can just do a simple web search for older driver packages and extract and place the correct files but I guess that's to much work for you.

AMD FX-8350 w/ Corsair H105, ASUS Sabertooth 990FX Gen3/R2, 8GiB G.SKILL DDR3-2133, XFX HD 7970, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, Corsair C70, HP ZR2440w, Win 7 Ultimate x64
 04/22/2013 10:28 AM
User is offline View Users Profile Print this message

Author Icon
Heavy Wizardry

Posts: 8065
Joined: 11/13/2009

Here are the legacy drivers for that card >


Intel I7 960 @ 3.87ghz *Intel DX58SO *AMD R9 290 4gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit 

***** cetera fallunt, ludere mortuus ******

 04/22/2013 11:18 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 5
Joined: 04/21/2013

After three days of heache and stressing, going to get my old card is by far the easiest thing to do.

I've tried that catalyst version.  I ran it in compatability mode for xp SP2 for both the extraction and the setup seperatly.
This is what happens when I run the setup:

 04/23/2013 08:58 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 5
Joined: 04/21/2013

This can pretty much be closed.  I just went and retrieved my other card from where I donated it.  It's working perfectly fine for Minecraft.
Thanks for the help, guys.

90366 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.