Topic Title: Bad Video Driver - trying to play Minecraft
Topic Summary: Minecraft, Bad Video Driver
Created On: 10/01/2013 09:54 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/01/2013 09:54 AM
User is offline View Users Profile Print this message

Author Icon
UWECEO
Peon

Posts: 1
Joined: 10/01/2013

My video driver is up-to-date according to AMD site and updater. I have tried numerous attempts to run Minecraft and still get the same error message "Bad Video Driver, Pixel format not accelerated"

 

I have the Radeon X1650 video card and does fine for - WoW, Doom3, and various other high graphic games that I play, so therefore I do not get why Minecraft will not run as well.

 

Any clues out there?

 

Info:

Windows 7 Sp1 64 bit

Radeon X1650

3GB Ram

2TB Hard drive space



-------------------------
I am UWECEO, you don't like it? Oh Well
 10/01/2013 12:52 PM
User is offline View Users Profile Print this message

Author Icon
spyre
Heavy Wizardry

Posts: 9117
Joined: 09/14/2007

That card is not supported for Windows 7 as the card is too old, also your card doesn't meet the min spec for Minecraft which is OpenGL 2.1 not OpenGL 2.0

 11/28/2013 12:02 PM
User is offline View Users Profile Print this message

Author Icon
cacooke
Peon

Posts: 1
Joined: 11/28/2013

I had the exact same problem while setting up a new (refurbished) Dell 755 MT for daughter and re-installing her Minecraft.Dell 755 MTIntel Core 2 Duo4 gb Ram160 GB HDWin7 Pro x64ATI x1650 add on video cardAfter reading all these posts everywhere that Minecraft would not work on an ATI x1650 (which I knew it would because that is what she was using before the new Dell) and Win7,  I continued pulling my hair out to find a solution.Here is what I found out:ATI Catalyst has to be installed and running or OpenGL will not load.Although it is recommended everywhere to install Catalyst 10.2, I could not get it to install correctly.  Others say to use 9.2 or 9.1.  I could not get ANY version of Catalyst to install correctly.Please note: These were the Catalyst drivers from ATI/AMD itself and other MS certified sites.I found ATI Catalyst 9.11 Legacy drivers that DO FINALLY INSTALL correctly.http://www.touslesdrivers.com/index.php?v_page=23&v_code=26820No viruses, Pup's or Trojans detected.Uninstall ALL traces of ATI drivers. (I use Revo Uninstaller to remove all traces).Uninstall .NETRebootReinstall .NETInstall 9-11_legacy_vista32-64_dd_ccc.exe that was downloaded from the above link.That's It!Hope this helps! 
Statistics
81111 users are registered to the AMD Support and Game forum.
There are currently 9 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.