Topic Title: Driver problem after upgrade to Windows 7 (FIXED)
Topic Summary:
Created On: 11/05/2013 12:20 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/05/2013 12:20 PM
User is offline View Users Profile Print this message

Author Icon
WJLIII3
Peon

Posts: 7
Joined: 11/05/2013

I downloaded the Catalyst suite, but it contains only options for my CPU, and my software still recognizes no video drivers. I have a Radeon X1950 PRO.



Edited: 11/06/2013 at 02:56 PM by WJLIII3
 11/05/2013 03:20 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

Back in he time the X1 series were used there were no CPU options in CCC. So something is seriously wrong on your end. You installed something not even made for your card.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 11/06/2013 10:02 AM
User is offline View Users Profile Print this message

Author Icon
Hardwood
Dungeon Master

Posts: 4029
Joined: 01/27/2008

My 1950pro AGP (listed below) is using Catalyst 10.2 legacy Vista 32-64 and the computer is running Win8.1. Just played Left 4 Dead with no issues. CCC works but fan control and heat might be an issue after awhile.



-------------------------

#1: FX-6350, Antec Kuhler 920, MSI 970 Gaming, Asus 5870/V2, ASUS Xonar D2X, GSkill (F3-14900cl9d-8gbxl), Antec Truepower New 750, Arc Midi, Win8.1pro x64
#2: MSI A88X-G45, AMD A10-7850K, IGP, AMD 2x4GB 2133 (R938G2130UK), Antec 750 True, 128GB Sandisk SSD, WD Black 1TB, Win8.1pro x64
#3: Athlon 64 X2 4200+, AGP 1950pro, Audigy 2, Asus A8V-D, 2gig ram, Enermax 465P, Antec900case. Now on Win8.1pro cat 10.2

 11/06/2013 12:06 PM
User is offline View Users Profile Print this message

Author Icon
WJLIII3
Peon

Posts: 7
Joined: 11/05/2013

Ok, when I used the site driver search, it simply directed me to "AMD Catalyst Suite" with no link of any kind, so searching for that I must have found too new of a version. Where did you find your legacy driver?

 11/06/2013 01:01 PM
User is offline View Users Profile Print this message

Author Icon
WJLIII3
Peon

Posts: 7
Joined: 11/05/2013

I downloaded 10.2 from another site and it made no difference. Can't even play Minecraft.

Also, how the hell do I uninstall the new Catalyst? The first one I got, not 10.2. I'm theorizing that may be my problem?

 11/06/2013 01:37 PM
User is offline View Users Profile Print this message

Author Icon
WJLIII3
Peon

Posts: 7
Joined: 11/05/2013

After completely scouring my drive of AMD products, then reinstalling the 10.2 I found, I ended up with precisely zip. Can someone, perhaps direct me to a better source?

I'd really appreciate it, I'm going nuts here. The Catalyst install manager is the most useless, unintuitive, unhelpful piuece of software I've ever run into that wasn't actually trying to steal my money. And thats not considering the fact that it doesn't work.

 11/06/2013 01:52 PM
User is offline View Users Profile Print this message

Author Icon
WJLIII3
Peon

Posts: 7
Joined: 11/05/2013

In fact, the Catalyst Install Manager, no matter what I ahve tried to do, has only so far managed to install itself, over, and over, and over again.

 11/06/2013 02:43 PM
User is offline View Users Profile Print this message

Author Icon
WJLIII3
Peon

Posts: 7
Joined: 11/05/2013

Hardwood, does yours come with the CIM? My old one did not.

 11/06/2013 02:54 PM
User is offline View Users Profile Print this message

Author Icon
WJLIII3
Peon

Posts: 7
Joined: 11/05/2013

Ok, DO NOT USE Guru3d for Catalyst 10.2 their download is like 8 months out of date, presumably the 8 months in which they invented modern gaming, because its the difference between not being able to launch minecraft and running Skyrim at high.

 11/06/2013 03:09 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

10.2 and 10.2 legacy are not the same thing. Probably you're trying to install the former.

Unfortunately the driver download page on amd.com still doesn't work. Just google "catalyst 10.2 legacy" and you'll find it somewhere else, just don't forget to include the word legacy.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

Statistics
85741 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.