Topic Title: HD 4000 Series drivers still not working on Windows 8
Topic Summary: 4870x2 drivers not working....
Created On: 11/26/2013 07:06 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/26/2013 07:06 PM
User is offline View Users Profile Print this message

Author Icon
rxpike
Peon

Posts: 3
Joined: 01/07/2009

I installed Windows 8 the day it came available, excited to see what it had in store. I was dissapointed to find that there was no available drivers for my card. Went back to Windows 7. Today I decided it was time to try again -- and again, same issue. I have tried the drivers for the legacy cards (12.6) and the actual display driver fails everytime.


My specs:

i7 965

6gb ddr3

ASUS Rampage II

HD 4780x2 (diamond)



It's like the card isn't being recognized, despite it working 20 minutes ago on Windows 7.

 

HELP!

 11/26/2013 07:58 PM
User is offline View Users Profile Print this message

Author Icon
Practikill
Grinding Levels

Posts: 103
Joined: 08/07/2009

It's considered a Legacy card, and thus is not supported on Win8.

There is no way of making it work properly. You need a new GPU for Win8.



-------------------------
 11/26/2013 07:59 PM
User is offline View Users Profile Print this message

Author Icon
rxpike
Peon

Posts: 3
Joined: 01/07/2009

Made a little progress... Got the device manager to finally read 4870x2 -- but it shows it's driver as WDDM v1.1 .

 

Under the driver tab it shows:
Driver provider: Advanced Micro Devices, INC.
Driver Date: 6/20/2012
Driver Version: 8.97.10.6

 11/26/2013 10:34 PM
User is offline View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12319
Joined: 04/17/2008

Because the HD 4000 series only supports WDDM 1.1, which is why it was moved to legacy status. Either use Windows 7 or upgrade your hardware.

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
 11/26/2013 11:54 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7168
Joined: 11/13/2009

Here read this.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

Statistics
84643 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.