Topic Title: HDMI Audio completely FUBARed after Windows 8.1 upgrade
Topic Summary:
Created On: 01/01/2014 02:04 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 01/01/2014 02:04 PM
User is offline View Users Profile Print this message

Author Icon
ibbibby
Peon

Posts: 5
Joined: 01/17/2013

I just upgraded to Windows 8.1 yesterday, and since then I've been unable to get my sound to work over HDMI.

It's capable of making *one* sound after Windows starts up, and after that it stops working.

If I try to test the speakers in Sound configuration, it gives me a dialog that says "The device is being used by another application. Please close any devices that are playing audio to this device and then try again"

I've had this problem before in the past, but I was able to make it go away by going into the Properties for the HDMI Output and deselecting the checkbox that says, "Allow applications to take exclusive control of this device." Now even that no longer fixes the problem.

I also thought of trying to uninstall the new drivers for the AMD High Definition Audio Device, and putting back the ones I had before, but unfortunately those ones were for Windows 7 64-bit, and it seems that Windows 8.1 will no longer allow me to use Windows 7 drivers.

The video card I'm using is a Radeon HD 4550 (Getting the video drivers to work in Catalyst again was another long and painful story, but I'm past that at least).

This is a home theater PC, hooked up to surround sound by HDMI, so without this working, my PC (and projector) is basically useless.  Somebody PLEASE help.

 01/01/2014 02:50 PM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

4000 series card is a Legacy card and a while back AMD announced that it wasn't supporting Legacy cards in Win 8.1 OS. WDDM 1.3 is not supported for Legacy cards and that is Windows 8.1 standard.

Read these two articles for more details.

http://support.amd.com/en-us/kb-articles/Pages/catalystlegacywin8.aspx

http://www.anandtech.com/show/5775/amd-hd-2000-hd-3000-hd-4000-gpus-being-moved-to-legacy-status-in-may



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

 01/01/2014 03:14 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

To cut the long story short:

Windows 7: Fully supported

Windows 8.0: Partial support

Windows 8.1: No support at all

 

Just get a windows phone for metro and go back to windows 7. If you're not using metro, why the downgrade to 8.1?



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

Statistics
85345 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.