Topic Title: A problem with HD 4600 series
Topic Summary:
Created On: 02/22/2014 11:32 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/22/2014 11:32 PM
User is offline View Users Profile Print this message

Author Icon
xBeekay
Peon

Posts: 5
Joined: 01/23/2014

I cannot update my driver. I've tried so many times, but after installing "13-1-legacy_vista_win7_win8_64_dd_ccc" I go to dxdiag, and it still says I've got WDDM 1.1 driver. 

I've tried going to device manager and uninstalling the WDDM 1.1 (Windows Display Driver Model), then unistalling everything related to ATI Catalyst with all the drivers using Driver Fusion. Then i installed the latest driver for my HD 4600 and rebooted the machine. After the reboot i went to check dxdiag and it still showed up WDDM 1.1.

I've got no clue what the hell is wrong, so please help me. 

 

 02/22/2014 11:34 PM
User is offline View Users Profile Print this message

Author Icon
xBeekay
Peon

Posts: 5
Joined: 01/23/2014

I would have added a text doc of dxdiag analysis but I dont know how :/

 02/22/2014 11:43 PM
User is offline View Users Profile Print this message

Author Icon
goodplay
Master Looter

Posts: 396
Joined: 08/21/2011

No,no dxdiag.

See "STICKY",for info required.



-------------------------

i5 3570k(@4.5)./ga-z77x-ud5h-wb./hyper T4./2 x 4gb vengeance 1600 c8./sapphire dualX 7970 3gb OC boost v2./1tb WD FAEX Black./lg bh10 blu-ray r.w../corsair hx850./antec df30./z506 spkrs./lg e2240v./win 8(8.1) pro x64 (oem disc)

 02/22/2014 11:54 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4846
Joined: 12/27/2008

WDDM 1.2 is Windows 8 with a 100% WDDM 1.2 compatible hardware. You cannot have WDDM 1.2 with a 4k series card and you cannot have WDDM 1.2 with Windows 7 or Vista. I hope it makes it clear for you. There is no error there, you see what you have to see. Now stop worrying and play some games instead.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 02/23/2014 12:08 AM
User is offline View Users Profile Print this message

Author Icon
xBeekay
Peon

Posts: 5
Joined: 01/23/2014

Graphics Card: ATI Radeon HD 4600 series, I dont really know what overlocking is but I checked BIOS and there was something "V6 Overclockin Tech"

AMD Catalyst Driver: at the moment I dont have any version of Catalyst, because no matter which one I install it still doesnt update my driver

OS: 64bit, it was the same case with 32bit though. It's always WDDM 1.1

Issue Details: I've already posted the issue ^

Motherboard: Manufacturer - Biostar group ; Model - TA790GXBE

Power Supply: I dont think it really matters in this case

Display Device: Samsung SyncMaster 932NW

CPU Details: Processor - AMD Athlon(tm) II X2 250 Processor (2 CPUs), ~3.0GHz ; RAM memory 4GB

Motherboard BIOS version: Default System BIOS

 

Hope these are going to help

 02/23/2014 12:09 AM
User is offline View Users Profile Print this message

Author Icon
xBeekay
Peon

Posts: 5
Joined: 01/23/2014

Originally posted by: Eydee WDDM 1.2 is Windows 8 with a 100% WDDM 1.2 compatible hardware. You cannot have WDDM 1.2 with a 4k series card and you cannot have WDDM 1.2 with Windows 7 or Vista. I hope it makes it clear for you. There is no error there, you see what you have to see. Now stop worrying and play some games instead.

 

Yeah, but when I start minecraft it gives me a crash report that says I've got an outdated driver

 02/23/2014 01:39 AM
User is offline View Users Profile Print this message

Author Icon
goodplay
Master Looter

Posts: 396
Joined: 08/21/2011

Have a look in the "How-To & FAQs"(first topic).

Windows updated?..Net Framework updated?

Latest legacy driver is 13.9,where are you downloading from(maybe faulty package).



-------------------------

i5 3570k(@4.5)./ga-z77x-ud5h-wb./hyper T4./2 x 4gb vengeance 1600 c8./sapphire dualX 7970 3gb OC boost v2./1tb WD FAEX Black./lg bh10 blu-ray r.w../corsair hx850./antec df30./z506 spkrs./lg e2240v./win 8(8.1) pro x64 (oem disc)

 02/23/2014 03:23 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4846
Joined: 12/27/2008

Originally posted by: xBeekay
Originally posted by: Eydee WDDM 1.2 is Windows 8 with a 100% WDDM 1.2 compatible hardware. You cannot have WDDM 1.2 with a 4k series card and you cannot have WDDM 1.2 with Windows 7 or Vista. I hope it makes it clear for you. There is no error there, you see what you have to see. Now stop worrying and play some games instead. [IMG][/IMG]

 

 

 

 

Yeah, but when I start minecraft it gives me a crash report that says I've got an outdated driver

 

It has nothing to do with the WDDM version. Minecraft even runs on XP with good old WDM. You're probably missing OpenGL drivers, that's why Minecraft is angry.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

Statistics
84143 users are registered to the AMD Support and Game forum.
There are currently 7 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.