Topic Title: Catalyst v13.1 does not want to be installed
Topic Summary: Catalyst and Driver v13.1 "successful installed" BUT NOT installed at all
Created On: 03/22/2014 04:41 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 03/22/2014 04:41 PM
User is offline View Users Profile Print this message

Author Icon
dpamd
Peon

Posts: 5
Joined: 03/22/2014

 

Please help - I struggled for days already!

Graphics Card

- AGP 8x: ATI Radeon HD 4670 AGP (RV730)

AMD Catalyst Driver Version, and Driver History
- Installed 12.4 before Worked OK. Uninstalled bc Sleep problem, with AMD utility. Trying to install 13.1 or at least 12.4

 

 Versions downloaded from AMD site:

13-1-legacy_xp32_dd_ccc_whql.exe

from: http://support.amd.com/en-us/download/desktop/legacy?product=legacy2&os=Windows%20XP%20-%20Professional/Home&RenderOnServer=true

12-4_xp32_dd_ccc.exe

When I installed v13.1 it seemed OK (see below log) but Catalyst and driver did not install (driver ?) and

directory C:\Program Files\ATI Technologies is empty - Catalyst is not installed!

Every windows show as in article:

http://support.amd.com/en-us/kb-articles/Pages/catalyst-windows-install.aspx#XP

but one thing: it did not prompt, Click Yes to restart (which I did anyway)

I followed all directions from article:

http://forums.amd.com/game/messageview.cfm?catid=454&threadid=167211&enterthread=y


Operating System
- Windows XP 32 Bit, Service pack 3

Motherboard or System Make & Model
- Asus A7N8X-LA

Power Supply

- ATX 600W

Display Device(s) and Connection(s) Used
- ACER 1024x768 17 Inch Screen VGA

CPU Details
- AMD Athlon XP, 2083 MHz (12.5 x 167) 2800+

 Motherboard BIOS Version

  - ASUS AMI 3.05

 Related Software installed:

 Microsoft .NET Framework 2.0 Service Pack 2 2.2.30729 185.2 MB

Microsoft .NET Framework 3.0 Service Pack 2 3.2.30729 208.7 MB

Microsoft .NET Framework 3.5 SP1 28.0 MB

Microsoft .NET Framework 3.5 SP1 3.5.30729

Microsoft .NET Framework 4 Client Profile 4.0.30319 RE-INSTALLED

Microsoft .NET Framework 4 Client Profile 4.0

.30319 Unknown and RE-INSTALLED

Microsoft .NET Framework 4 Extended 4.0.30319 Unknown and RE-INSTALLED

Microsoft .NET Framework 4 Extended 4.0.30319 Unknown and RE-INSTALLED

Microsoft .NET Framework 4 Multi-Targeting Pack 4.0.30319 83.5 MB and RE-INSTALLED

Microsoft .NET Framework 4.03 Installed

Microsoft Visual C++ 2005 Redistributable 8.0.50727.42 5.1 MB

Microsoft Visual C++ 2005 Redistributable 8.0.61001 5.3 MB

Microsoft Visual C++ 2008 Redistributable - x86 9.0.21022 9.0.21022 8.1 MB

Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.17 9.0.30729 10.3 MB

Microsoft Visual C++ 2008 Redistributable - x86 9.0.30729.6161 9.0.30729.6161 10.2 MB

Microsoft Visual C++ 2010 x86 Redistributable - 10.0.30319 10.0.30319 1.3 MB and RE-INSTALLED

INSTALLATION LOG

Catalyst™ Install Manager

Installation Report

03/22/14 11:07:39

Hardware information

Name AMD Radeon Graphics Processor

Manufacturer Advanced Micro Devices, Inc.

Device ID 0x9495

Vendor ID 0x1002

Class Code 0x030000

Revision ID 0x00

Subsystem ID 0x0028

Subsystem vendor ID 0x1002

Other hardware

 Existing packages

Microsoft Visual C++ 2010 Redistributable

 Packages for install

 

AMD Catalyst Install ManagerFinal Status: Success

Version of Item: 8.0.877.0

Size: 20 Mbytes

Other detected devices

 

Manufacturer Advanced Micro Devices, Inc.

Device ID 0xaa38

Vendor ID 0x1002

Class Code 0x040300

Revision ID 0x00

Subsystem ID 0xaa38

Subsystem vendor ID 0x1002

 

AMD Radeon Graphics Processor

Manufacturer Advanced Micro Devices, Inc.

Device ID 0x9495

Vendor ID 0x1002

Class Code 0x030000

Revision ID 0x00

Subsystem ID 0x0028

Subsystem vendor ID 0x1002

 

Manufacturer Advanced Micro Devices, Inc.

Device ID 0xaa38

Vendor ID 0x1002

Class Code 0x040300

Revision ID 0x00

Subsystem ID 0xaa38

Subsystem vendor ID 0x1002

 

Error messages

--------------END OF LOG---------------

 

 

 

 

 

 I HAD TO RE_INSTALL AGAIN - after I cleaned with Uninstaller and looked for some registry pertaining to ATI, I re-installed v13.1, WITH SAME RESULTS AS BEFORE (not installed), see log:

Catalyst™ Install Manager
Installation Report
03/22/14 21:51:27


Hardware information
Name AMD Radeon Graphics Processor
Manufacturer Advanced Micro Devices, Inc.
Device ID 0x9495
Vendor ID 0x1002
Class Code 0x030000
Revision ID 0x00
Subsystem ID 0x0028
Subsystem vendor ID 0x1002
Other hardware
 
Existing packages
Packages for install
AMD Catalyst Install ManagerFinal Status: Success
Version of Item: 8.0.877.0
Size: 20 Mbytes
HDMI Audio DriverFinal Status: Success
Version of Item: 5.18.0.5514
Size: 1 Mbytes

Other detected devices
 
Manufacturer Advanced Micro Devices, Inc.
Device ID 0xaa38
Vendor ID 0x1002
Class Code 0x040300
Revision ID 0x00
Subsystem ID 0xaa38
Subsystem vendor ID 0x1002
 
AMD Radeon Graphics Processor
Manufacturer Advanced Micro Devices, Inc.
Device ID 0x9495
Vendor ID 0x1002
Class Code 0x030000
Revision ID 0x00
Subsystem ID 0x0028
Subsystem vendor ID 0x1002
 
 
Manufacturer Advanced Micro Devices, Inc.
Device ID 0xaa38
Vendor ID 0x1002
Class Code 0x040300
Revision ID 0x00
Subsystem ID 0xaa38
Subsystem vendor ID 0x1002

Error messages
 
--------------END LOG2 ------------

 

 

 

 

 Here it is what was installed (use slow download):

 

 

 

 

 

 

 

 

 

 

http://www.fileswap.com/dl/eLAzy8Psq/ATi_Install.doc.html]File "ATi Install.doc"

 

 

 

 

 

 

 



Edited: 03/23/2014 at 06:32 PM by dpamd
 03/22/2014 08:12 PM
User is offline View Users Profile Print this message

Author Icon
heykay
Peon

Posts: 1
Joined: 03/22/2014

I hope someone can help with this, because this is my exact problem. I follow every step to update and install my drivers. I go through the installation process and it goes to finished. No error messages, no restart prompts. Nothing is installed. I haven't been able to update my drivers since I got my computer

 03/23/2014 11:11 AM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4849
Joined: 12/27/2008

Use an older version or OEM drivers. It won't affect performance, there haven't been anything for the 4k series in the drivers for many years. You can also mod the drivers if you really want to. Just add the hardware id of your card to the driver inf file.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 03/23/2014 06:19 PM
User is offline View Users Profile Print this message

Author Icon
dpamd
Peon

Posts: 5
Joined: 03/22/2014

I am surprised you say that these 2 versions  12.4 and 13.1 are not for HD 4000 series 

Please check:

AMD Catalyst™ Software Suite Version 12.4 Release Notes

http://support.amd.com/en-us/kb-articles/Pages/AMDCatalystSoftwareSuiteVersion124ReleaseNotes.aspx

AMD Desktop Product Family Compatibility  ATI Radeon HD 4670 Series

 

 

AMD Catalyst™ Driver for AMD Radeon™ HD 4000, HD 3000 and HD 2000 Series

http://support.amd.com/de-de/download/desktop/legacy?product=legacy2&os=Windows

Catalyst Software Suite 144.5 MB 13.1 21.01.2013 Download

 

AMD Catalyst™ Driver for AMD Radeon™ HD 4000.. Series v13.1 v13.9

Applicable Products: This article applies to the following configuration(s):

Hardware: AMD Radeon HD 4000 Series      AMD Radeon HD Series AGP

http://support.amd.com/de-de/download/desktop/legacy?product=legacy2&os=Windows

 

Thank you for your answer! I need some details though to fill in...

Which INF file? like:

\AMD\Support\13-1-legacy_xp32_dd_ccc_whql\Packages\Drivers\Display\XP_INF\CX160538.inf

the line like:

"%AMD9598.3%" = ati2mtag_RV630, PCI\VEN_1002&DEV_9598&SUBSYS_30001043

I should add my AMD4670  ? Is it a way to retrieve ALL info to make that line?

If this is the case all I know about my card is:

AGP 8x: ATI Radeon HD 4670 AGP (RV730) Memory Size 1 GB

PCI Device 1002-9495 / 1002-0028  (Rev 00)

GPU Clock 749 MHz  (original: 750 MHz)

GPU Code Name RV730 Pro

BIOS Version 011.022.006.000.000000

Part Number 113-SBRK2G02-10R-01

 

Should I add:

"%AMD4670.1%" = ati2mtag_RV730, AGP\VEN_1002&DEV_4670&SUBSYS_?????????

I do not know about the 1 after 4670 and AGP or PCI:

%AMD4670.1% and subsys:

SUBSYS_????????? I am missing subsys

...how would it work if I do not know subsys #?

On the other hand: can you point me which OEM driver?

...Thank you for your detailed expected answer!



Edited: 03/23/2014 at 07:56 PM by dpamd
 03/24/2014 12:53 AM
User is offline View Users Profile Print this message

Author Icon
dpamd
Peon

Posts: 5
Joined: 03/22/2014

I checked file CX160538.inf from:

C:\AMD\Support\13-1-legacy_xp32_dd_ccc_whql\Packages\Drivers\Display\XP_INF

and I found these lines:

"%AMD9498.5%" = ati2mtag_R7X, PCI\VEN_1002&DEV_9498&SUBSYS_29331682

"%AMD9498.6%" = ati2mtag_R7X, PCI\VEN_1002&DEV_9498&SUBSYS_29341682

AMD9498.5 = "ATI Radeon HD 4670"

AMD9498.6 = "ATI Radeon HD 4670"

 

From these lines it looks like my card ATI Radeon HD 4670 IS in the scope of the INF file, but I am not sure what the lines mean

 What is your opinion?

 03/24/2014 02:32 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4849
Joined: 12/27/2008

I never said those drivers were not for 4k series, I said there wasn't anything new in them.

To get the hw id of your card, find it in device manager, double-click it, go to the details tab, and use the dropdown list to select the hardware id.

Your only tak is finding a similar card in the inf file (e.g. another 4670), replace the hardware id to yours and save the file.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

Statistics
84320 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.