Topic Title: Setup will only run in administrator mode
Topic Summary: x300SE install on XP is not working
Created On: 08/20/2014 07:44 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/20/2014 07:44 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 08/20/2014


I am trying to install a 256mb x300SE on Windows XP SP3 32 bit, and when I try to install it says "Setup will only run in Administrator mode, setup is aborting".

I am logged in with the Administrator account, the machine is not joined to a domain. I have tried installing via the setup.exe file, the setup in the driver file subdirectory, directly adding the driver file via Device manager, all of these both in a normal login and in Safe Mode. I have tried compatibility mode, Run As, running it as a different Administrator level account, and sacrificing a small goat. Nothing is working.

The closest I can get is adding the driver via Device Manager, but then I get a "Device could not be started" error. The device itself seems to be fine, I'm typing this in VGA mode on the machine, but I can't get the driver installed.


Further, when I try to download a legacy version of the drivers via, I get a list of 2 previous versions, but neither has any clickable link anywhere in the page that I can find, both in Chrome and IE.


I would appreciate any advice that could get this driver installed, or a link to an older version of the driver file that works.

 08/20/2014 09:23 PM
User is online View Users Profile Print this message

Author Icon
Heavy Wizardry

Posts: 8810
Joined: 11/13/2009

Old Drivers


Intel I7 960 @ 3.87ghz *Intel DX58SO *AMD R9 290 4gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit 

***** cetera fallunt, ludere mortuus ******

93351 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.