Topic Title: HD 4870 TDR Blue screens and artifacts
Topic Summary: TDR BSOD since last week
Created On: 08/24/2014 05:42 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/24/2014 05:42 PM
User is offline View Users Profile Print this message

Author Icon
yankee penky

Posts: 4
Joined: 08/24/2014


My HD4870 suddenly started having issues this week without any previous hints of a faulty card.

Graphics Card
Sapphire HD4870
Never overclocked and originally bought by myself - new card
750 clock / 900 memory

AMD Catalyst Driver Version, and Driver History
13.9 tried today and current, tried 12.6 / had 13.1 till yesterday

Operating System
Windows 7 x64 SP1

Issue Details
Yesterday I tried to play skyrim again and after about 2 seconds ingame my screen went black and after another 2 seconds I got a BSOD error 116 TDR.

Then I tried installing the current driver, with previous driver cleanup in safe mode etc... Nothing changed. I also tried running a memtest for vRAM and RAM both successfully for about 60 passes.

I was able to collect some temperature and usage data but nothing special:
gpu idle about 40°C then the game loaded and usage rose to 99% temperature to 60°C memory about 250MB dedicated 25MB shared then the blue screen appeared and the collection stopped.

I've already cleaned my whole pc from dust and checked my PSU, the strange thing is why did it appear now, after more than 2 years flawless work?

Motherboard or System Make & Model
MSI P35 Neo2 FIR

Power Supply

Enermax Pro82+ 525W

Display Device(s) and Connection(s) Used

LG FLatron W2486L & SyncMaster 940B

both connected via DVI

Applications and Games

Skyrim, Hawx2 DX11, FurMark Benchmark & 3d Mark

CPU Details
Intel Core2 Extreme X9650 3.0 GHz
never overclocked

Motherboard BIOS Version
AMI BIOS 1.12 (latest)

System Memory Type & Amount
4x Kingston DDR 1GB 800MHz

Additional Hardware
1 Case Fan, Booting from Crucial SSD 128GB.

Additional Details
tried prime95 CPU OK
tried memtest RAM OK
tried vRAM test OK

I don't know what else to do... I don't have the paid version of 3dMark because of that I was only able to run the full HD benchmark. Is there any tool to simulate 3d graphics and run a stress test other than FurMark?

The really strange thing is:
Everything worked fine till Friday, I havent played anything since last MS patchday. But 1 month ago I was able to play Hawx2 and skyrim without problems.

Anny suggestions?

 08/24/2014 06:49 PM
User is offline View Users Profile Print this message

Author Icon
Heavy Wizardry

Posts: 8680
Joined: 11/13/2009

Maybe windows update installed something it shouldn't have. Check your installed updates, looking for anything AMD. Or try a restore point before the last updates.


Intel I7 960 @ 3.87ghz *Intel DX58SO *AMD R9 290 4gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit 

***** cetera fallunt, ludere mortuus ******

 08/24/2014 08:17 PM
User is offline View Users Profile Print this message

Author Icon
80 Column Mind

Posts: 13508
Joined: 04/17/2008

Could be starting to go bad.

AMD FX-8350 w/ Corsair H105, ASUS Sabertooth 990FX Gen3/R2, 8GiB G.SKILL DDR3-2133, XFX HD 7970 GHz Edition, 1TB Samsung 850 Evo, 256GB OCZ Vector, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, Corsair C70, HP ZR2440w, Win 7 Ult Ed x64
 08/26/2014 02:18 PM
User is offline View Users Profile Print this message

Author Icon
yankee penky

Posts: 4
Joined: 08/24/2014

okay thank you for your first replies...

I did a little bit of testing and yesterday I've finally noticed that while my pc was booting the card didn't test it's fan (test high performance mode?)

It stopped doing that already some weeks ago - so I think my PSU is damaged or simply old (after 4-5 years).

I am going to test the voltages but anyhow I think it must be this.

92815 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.