Topic Title: Windows 8.1 black Screen Radeon HD 7970
Topic Summary:
Created On: 10/30/2013 09:51 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/30/2013 09:51 AM
User is offline View Users Profile Print this message

Author Icon
BeeGeePee
Peon

Posts: 4
Joined: 10/30/2013

Hello,

 

My computer uses a Sapphire Radeon HD 7970 3GB GDDR5 OC with BOOST: 

 

http://www.sapphiretech.com/presentation/product/product_index.aspx?pid=1481&lid=1

 

Here are the components of my PC:

 

http://pcpartpicker.com/p/1s2nB

 

I tried to update windows 8 to windows 8.1.  During the installation process I noticed a few times it said there were errors in the process, but it eventually seemingly successfully installed it.  

 

However, when windows 8.1 booted up, I noticed the graphics were messed up (i.e. wrong resolution etc.)  So, I installed the newest *Beta graphics drivers 13.11 for my graphics card which can be found here:

 

http://support.amd.com/en-us/download/desktop?os=Windows%208.1%20-%2064

 

(I chose that one because I noticed there was no 8.1 drivers released by Sapphire for this GPU.) 

 

During this installation, the computer completely crashed.  It then tried to restart several times, and windows tried to automatically fix the problem.  I tried to do that automatic start-up repair (said it would check disk which could take up to an hour) but that didn't do anything.  

 

I then did a restore to a point prior to updating to 8.1 or installing the new graphics drivers.  (time was 3AM 10/29/2013).  It STILL did not load up properly even though it said it successfully restored my computer to a time when it was working perfectly fine.

 

I rebooted my computer and spammed F2 and F8 (wasn't sure which allowed me to view my boot options).  I reset my motherboard to the default UEFI settings (I had done some OC tweaking which was very stable prior to any of this).  

 

However, none of this fixed my issue.  When I restart my computer it shows the little blue windows logo (4 blue squares) with a little loading thing under it.  After a few seconds the screen goes completely blank.  So, I don't know if windows is just not loading or if it is loading but my graphics card isn't working.

 

I can get my computer to load windows 8.1 in safe mode right now.  But now when I try and install drivers it says "Failure to load detection driver".  I have tried to install several different drivers.  Some of your old Sapphire drivers for this card as well as some of the older drivers for the card released by Radeon.  It appears there is something wrong with Catalyst Control Center.  I cannot repair CCC while I am in safe mode, but I cannot access windows in a regular boot. 

 

I was wondering if you have any suggestions on how I might fix this.  Is it possible i could load windows properly if I just disable/remove my graphics card and just run my MOBO's integrated graphics card?  

 

Any help would be immensely appreciated,

 

BeeGeePee

 11/07/2013 11:14 AM
User is offline View Users Profile Print this message

Author Icon
willthetrain
Peon

Posts: 2
Joined: 11/07/2013

This appears to be one of a number of glitches with Windows 8.1 which Microsoft are attemting to fix.

After 3 hour session with a Tech Guru from Microsoft yesterday, there appears to be no resolution as solutions to  numerous problems have not yet been produced

The only way I can avoid the Black Screen is to press the F8 button repeatedly after switching the laptop on.

I am stuck with the Microsoft Basic Display Adapter until an updated Mobility Radeon X2300 is produced

 

 11/07/2013 12:09 PM
User is offline View Users Profile Print this message

Author Icon
BeeGeePee
Peon

Posts: 4
Joined: 10/30/2013

So, after I got it to boot into safe mode, I ran CCleaner and cleared everything it possibly could as well as fixing all registry issues. ((Not sure which forum I found this on sorry)

Then, I ran driver sweeper. Again, I analyzed and cleaned everything it found. (Not sure which forum I found this on sorry)

I uninstalled Lucid VirtuMVP (suggested by MONSTA!)

Let it restart in normal mode and TADAAA!!! it actually loaded up (on my MOBO's gpu).

Then I installed the beta 13.11 drivers for my specific GPU (from AMD's website). I lost signal from my HDMI (connected to MOBO) so I switched to DVI connection (connected to Dedicated GPU) TADAAAA! working computer again!

Been a rough and long 2 days searching forums, troubleshooting, and trial and error. But this so far seems to have fixed the issue (fingers crossed).

Again thanks everyone! Hope this helps others with the same issue!

BEEGEEPEE

Statistics
87614 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.