Topic Title: 12.8 drivers not installing correctly on Windows 8.
Topic Summary:
Created On: 08/15/2012 11:59 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/15/2012 11:59 PM
User is offline View Users Profile Print this message

Author Icon
aben2amu
Peon

Posts: 7
Joined: 08/15/2012

These drivers are not working for Windows 8, my graphics card Radeon 6850 is not recognized.

 08/16/2012 06:09 AM
User is offline View Users Profile Print this message

Author Icon
Eydee
Dungeon Master

Posts: 4288
Joined: 12/27/2008

http://forums.amd.com/game/faq.cfm



-------------------------

CPU: AMD Phenom II X4 810 @ 3250MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 850/1150MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 7 Pro x64

CPU: Pentium 4 Northwood S478 @ 3200MHz | RAM: 1,5GB DDR 400| MoBo: Gigabyte GA-8S661FXMP-RZ | GPU: ASUS Radeon X1650 Pro 256MB | Display: Dimarson 19" CRT | PSU: Noname 400W | OS: changing twice every week...

 08/16/2012 11:33 AM
User is offline View Users Profile Print this message

Author Icon
aben2amu
Peon

Posts: 7
Joined: 08/15/2012

AMD Phenon II X4 940

8 GB RAM

Windows 8 Pro 64

AMD Radeon HD 6850

 08/16/2012 01:28 PM
User is offline View Users Profile Print this message

Author Icon
Russ@AMD
Forum Moderator

Posts: 27
Joined: 07/30/2012

Hi aben2amu,

Ideally, we need more information from you to better understand your situation.

Is your Radeon HD 6850 able to POST? If so, are you able to install from the link provided? Can you provide more information on any actual errors that you see?

AMD Catalyst Driver Windows® 8 Release Preview

http://support.amd.com/us/kbarticles/Pages/Windows8ConsumerPreviewDrivers.aspx

Note! This driver is provided "AS IS" and under the terms and conditions of the End User License Agreement provided therewith.

If the issue continues, please submit a report directly to us for further review or call us directly.

AMD Issue Reporting Form

www.amd.com/report

AMD Global Technical Support

http://support.amd.com/us/contacts/Pages/global-technical-support.aspx


Regards,

Russ@AMD



-------------------------

AMD Customer Care

The information presented in this do*****ent is for informational purposes only and may contain technical inaccuracies, omissions or typographical errors. Links to third party sites are for convenience only, and no endorsement is implied



Edited: 08/16/2012 at 02:27 PM by Russ@AMD
 08/16/2012 03:21 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Dungeon Master

Posts: 4288
Joined: 12/27/2008

@Russ:

The Release Preview drivers surely won't install on Windows 8 RTM. You can only use them by forcing install through device manager. 12.8 is a much better option.



-------------------------

CPU: AMD Phenom II X4 810 @ 3250MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 850/1150MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 7 Pro x64

CPU: Pentium 4 Northwood S478 @ 3200MHz | RAM: 1,5GB DDR 400| MoBo: Gigabyte GA-8S661FXMP-RZ | GPU: ASUS Radeon X1650 Pro 256MB | Display: Dimarson 19" CRT | PSU: Noname 400W | OS: changing twice every week...

 08/16/2012 03:25 PM
User is offline View Users Profile Print this message

Author Icon
aben2amu
Peon

Posts: 7
Joined: 08/15/2012

This is Windows 8 RTM not RP.

AMD claims that 12.8 is Windows 8 compatible so why is it that when I install it, the driver fails to install even though there is no error message? It fails because CCC is empty, there is no info about my Radeon HD 6800 series graphics card.

Nevermind, got it installed via Device manager as Eydee suggested.

Thanks.



Edited: 08/16/2012 at 03:31 PM by aben2amu
 08/16/2012 03:26 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Dungeon Master

Posts: 4288
Joined: 12/27/2008

It did install fine for me.



-------------------------

CPU: AMD Phenom II X4 810 @ 3250MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 850/1150MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 7 Pro x64

CPU: Pentium 4 Northwood S478 @ 3200MHz | RAM: 1,5GB DDR 400| MoBo: Gigabyte GA-8S661FXMP-RZ | GPU: ASUS Radeon X1650 Pro 256MB | Display: Dimarson 19" CRT | PSU: Noname 400W | OS: changing twice every week...

Statistics
81040 users are registered to the AMD Support and Game forum.
There are currently 6 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.