Topic Title: 5830 Crossfire Software Issue
Topic Summary: Looking for insight
Created On: 09/19/2012 01:50 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 09/19/2012 01:50 PM
User is offline View Users Profile Print this message

Author Icon
the7thcolumn
n00b

Posts: 5
Joined: 10/19/2011

Following the FAQ guide to posting I would ask you look over a issues I am currently having.

When I run some games in crossfire they will freeze as soon as there is something renderd. For example, the game menu will run fine (unless it is rendering something) but as soon as the level loads the game will freeze.

Alt+Tabbing will cause the audio to coninue and 1 frame to advance but then it will freeze again. The application never crashes.

Games that are affected are while in crossfire are:
Borderlands
Borderlands 2
Portal 2
*all these games work fine in single fire.


Games that work fine in crossfire are:
Battlefield 3
Counter-Strike: Source

Hardware:
ASUS P8P67Pro
16GB G.Skill Ram
60GB Corshair SSD
i7-2600k
XFX ATi 5830
XFX ATi 5830
XFX850w PSU

Software:
Windows 7 x64 - SP1 *fresh install
ATi CCC 12.8
Latest CAP (Included a update for borderlands 2)
BIOS Version - 3207 (Newest)

Can anyone shed some light on this?

 09/19/2012 02:01 PM
User is offline View Users Profile Print this message

Author Icon
the7thcolumn
n00b

Posts: 5
Joined: 10/19/2011

http://forums.steampowered.com/forums/showpost.php?p=25875127&postcount=9

I have found a way around this but I have to force the AA and one other setting see here.

 09/19/2012 02:53 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7079
Joined: 11/13/2009

Thanks for posting the tip



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 09/19/2012 05:52 PM
User is offline View Users Profile Print this message

Author Icon
the7thcolumn
n00b

Posts: 5
Joined: 10/19/2011

Yeah its not a bad tip, more of a work around.

Any other AA xNN setting will cause the crossfire to fail. Other users have reported the same thing.

So setting trhe AA to 16x allows me to play borderlands 2, but when I quit the PC will BSOD.

APCI - 15

"The embedded controller (EC) returned data when none was requested. The BIOS might be trying to access the EC without synchronizing with the operating system. This data will be ignored. No further action is necessary; however, you should check with your computer manufacturer for an upgraded BIOS."

I am current BIOS version as of right now.

 12/07/2012 01:12 PM
User is offline View Users Profile Print this message

Author Icon
ZW
Peon

Posts: 2
Joined: 12/07/2012

I have 2 5830's in crossfire and cannot get Borderlands 2 to work in crossfire mode.  I have tried absolutely everything under the sun.  There is a way to allow it to run in crossfire mode by unchecking "Use application settings" under "SmoothvisionHD Anti-Aliasing".  But when I do this, the game looks like crap and cant get above 30 fps and there is a strange border around my screen.  So I'm stuck running the game in "windowed" mode which doesnt allow me to take advantage of crossfire capabilities.I've had no issues running crossfire with Starcraft 2 or Diablo 3.  I've contacted 2K games which has not provided a solution over the passed 2 weeks I've been e-mailing them back and forth. Also requested support from AMD over a week ago and have not gotten a response yet.Really disappointing to spend all this money on 2 graphics cards and not get any support on them.
 12/12/2012 09:37 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7079
Joined: 11/13/2009

Originally posted by: ZW I have 2 5830's in crossfire and cannot get Borderlands 2 to work in crossfire mode.  I have tried absolutely everything under the sun.  There is a way to allow it to run in crossfire mode by unchecking "Use application settings" under "SmoothvisionHD Anti-Aliasing".  But when I do this, the game looks like crap and cant get above 30 fps and there is a strange border around my screen.  So I'm stuck running the game in "windowed" mode which doesnt allow me to take advantage of crossfire capabilities.I've had no issues running crossfire with Starcraft 2 or Diablo 3.  I've contacted 2K games which has not provided a solution over the passed 2 weeks I've been e-mailing them back and forth. Also requested support from AMD over a week ago and have not gotten a response yet.Really disappointing to spend all this money on 2 graphics cards and not get any support on them.

All crossfire setups should have ULPS disabled. Please Google it yourself.

Or > Go to registry and disable Ulps:

[HKEY_LOCAL_MACHINE\\SYSTEM\\ControlSet001\\Control \\Class\\{4D36E968-E325-11CE-BFC1-08002BE10318}]

and change "EnableUlps" to 0 under the 0000 and 0001 and 0003 keys.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

Statistics
84320 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.