Topic Title: C++AMP, HD6970, Win 8, and New Drivers 9.002 & 9.01.8
Topic Summary: New Drivers Worsened C++AMP Performance
Created On: 10/26/2012 11:34 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/26/2012 11:34 AM
User is offline View Users Profile Print this message

Author Icon
hystaspes
n00b

Posts: 1
Joined: 10/26/2012

Hey there,I just reported this using the link in AMD Issue Reporting Form post. Just want to know if anyone else having problems with new drivers' performance in C++ AMP?Switched to Catalyst 12.10 (9.002 driver) and the performance of the C++AMP applications got three times worse, from ~5 ms using Catalyst 12.8 to ~15 ms using Catalyst 12.10; when I changed to 12.11 beta it got worse and up to ~35 ms.It was fixed the moment I changed my driver to the one on Windows update (named AMD WDDM 1.2 driver for Radeon HD6000 series) but now I can't use Catalyst Control Center !Usually I don't use Catalyst Control Center but it's somewhat frustrating to see the performance worsened 3 to 6 times using the new drivers.Anyone else experienced this?P.S.: honestly AMD people, dont you guys test these drivers before releasing them?
Statistics
84341 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.