Topic Title: Where are my Windows 8 drivers?
Topic Summary:
Created On: 10/27/2012 12:38 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/27/2012 12:38 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 10/27/2012

As Windows 8 has now been officially released I was hoping to get some drivers for my HD4850. From the amd website I could gather that there are only legacy drivers available. Well, these have several problems under Windows 8 and I can't use the newer drivers. The drivers I got via Windows update are basically useless for anything other than Office. No hardware acceleration in photoshop, no OpenGL in Cinema 4D.

Can I expect somehing new on this soon? If not this surely was my last ati card I bought. And it woldn't be just for being left out with the drivers after only about 3 years. Nvidia would at least have Cuda as well....

 10/27/2012 12:42 PM
User is online View Users Profile Print this message

Author Icon
Heavy Wizardry

Posts: 8815
Joined: 11/13/2009


Intel I7 960 @ 3.87ghz *Intel DX58SO *AMD R9 290 4gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit 

***** cetera fallunt, ludere mortuus ******

 10/27/2012 07:08 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 3
Joined: 10/27/2012


I posted this over at the Adobe Photoshop forums, and I'll repost here.  This worked for me, solving Photoshop and OpenGL issues with my Radeon HD 4980 it seems.  Didn't realize this was a problem with all OpenGL!  Minecraft wouldn't even start with the default driver. 

Specifically, I followed these steps: 

Downloaded drivers from: onaiw-vista64.aspx

Unpacked files (run it or extract with 7-zip) but cancelled Catalyst install process after unpacking.

Went to device manager (control panel -> device manager or winkey+x -> device manager)

Right clicked my card under Display Adapters -> 'Update Driver Software...'

Click 'Browse My Computer For Driver Software', then 'Let me pick from a list of devices on my computer', then 'Have Disk', then 'Browse' and find the directory where the drivers are in the package you just extracted.

Example: 'C:\AMD\Support\12-6-legacy_vista_win7_64_dd_ccc_whql\Packages\Driver s\Display\W76A_INF'

Example: 'C:\AMD\Support\12-4_mobility_vista_win7_64_dd_ccc\Packages\Drivers\D isplay\W76A_INF'


Here I had two inf files and I wasn't sure if I needed the one that began C7 or CH.  I guessed C7.

Clicked next, drivers installed, screen flickered - Photoshop and Minecraft both working fine.


For those of you on Mobility devices, there's some specific steps here: the-fix/#entry15523571


LockerGnome echos these steps for both mobility and desktop cards, giving them some credit: rivers-work-in-windows-8/


But I was not at all able to find the LH6A_INF folder he mentions, just W76A_INF

I'm also not going to try the "bcdedit" commands he recommends until I see reason to, like if the driver reverts after reboot or Windows Update or something.  Nor have I seen any graphical issues in Metro yet.


Again - Photoshop GPU functions and other OpenGL applications like Minecraft seem to be working fine.


------------------------- - Reviews / Photography / Arts / Articles
SpaceCatSamba - Fan Art & Winamp Skins

 11/22/2012 02:49 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 3
Joined: 11/22/2012

This workaround just solved my OpenGL problems I had

under Windows8 with my Radeon HD 4290. Thanks.

 11/23/2012 05:01 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 11/23/2012

This workaround fixes OpenGL support, but breaks video streaming in metro apps. Even playing local video files is broken.

93380 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.