Topic Title: [12.10] Catalyst Control Center: Host application has stopped working??
Topic Summary: Great....12.10 installed, but CCC refuses to work.
Created On: 10/27/2012 02:07 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/27/2012 02:07 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 01/24/2010

Hi guys,


I hope someone can help me out on this one.
I installed 12.10, but that thing just refuses to work.

 And i installed it twice, but i still get the same error during start-up:

Catalyst Control Center: Host application has stopped working

Even a manual start of CCC won't work, 


Got NET 4.0 installed, removed everything of the old driver and even disabled firewall and anti-virus.

So what could cause this??


For now it looks i'll be stuck with version 12.8, or maybe reconsider installing a fresh copy of Win7.

 10/27/2012 11:31 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 14
Joined: 08/27/2012

It is sort of difficult without knowing what type of video card you have installed and computer configuration. 

Check to be sure NET 4.0 is properly installed and working. Many people suggest using Driver Fusion in safe mode to eliminate all traces of Amd Catalyst Driver package.  Reinstall again and leave everything in default. Afterwards check device Manager to see it the driver is installed without any problems or trouble. also check to see if there are any Yellow Exclamation signs on any of your drivers in Device Manager. I would also suggest to run a good Registry cleaner to delete any registers with old AMD Catalyst Driver packages. I personally use Advanced System Opitmizer Registry Cleaner and Optimizer and CCleaner afterwards.  I installed 12.10 on my computer with no problems and it solved all the problems in both 12.6 & 12.8.

As soon as you post your computer hardware and possibly software like games you play, Etc, I am sure you will get more responses to your problems with AMD Driver 12.10 .


Ellis D. Rodriguez

93055 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.