Topic Title: 7850 - signature not recognized and directx 11 not working
Topic Summary:
Created On: 11/01/2012 03:02 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/01/2012 03:02 PM
User is offline View Users Profile Print this message

Author Icon
Calrissian
n00b

Posts: 6
Joined: 05/07/2009

I've been having trouble getting my new MSI 7850 to work.  When installing new drivers (whether from AMD or MSI), the driver signature is not recognized, and I'm having to disable driver signatures to get it to load.  When I disable signatures, the card loads and runs fine, except it won't run DirectX 10 or 11.  Here's some data from the dxdiag:

    DirectX Version: DirectX 11

   Driver Name: aticfx64.dll,aticfx64.dll,aticfx64.dll,aticfx32,aticfx32,aticfx32,atiumd64.dll,atidxx64.dll,atidxx64.dll,atiumdag,atidxx32,atidxx32,atiumdva,atiumd6a.cap,atitmm64.dll
Driver File Version: 8.17.0010.1151 (English)
     Driver Version: 9.2.0.0
        DDI Version: 9Ex
       Driver Model: WDDM 1.1
  Driver Attributes: Final Retail
   Driver Date/Size: 9/27/2012 20:41:40, 1120768 bytes
        WHQL Logo'd: Yes

Any ideas on how to troubleshoot?  When I've uninstalled the old drivers (which I've done several times now), I've used a driver cleaner in safe mode to see if there was a relic from the old driver that was causing the problem.

This replaced an old 4850 if that helps.

Thanks for any advice.

 11/01/2012 03:16 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

Sounds like an OS issue. If the drivers were at fault, there would be thousands of people experiencing the same thing.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 11/01/2012 03:37 PM
User is offline View Users Profile Print this message

Author Icon
Canis-X
Forum Moderator

Posts: 719
Joined: 08/28/2012

What "driver cleaner" did you use....and....where did you download it from?  Not all driver cleaners are equal.  I would recommend that you go through the uninstall process again but this time use Driver Fusion to clean up the old driver stuff on your machine before installing the new.

Assuming that you did not use Driver Fusion.



-------------------------

The opinions expressed above do not represent those of Advanced Micro Devices or any of their affiliates.
Requiescat In Pace AMD Processor Forums | Member since: 1/19/2009 | Post count:
4142
Please don't PM me with questions, instead create a thread so that everyone can assist and benefit from the knowledge provided. Thanks in advance!

 11/01/2012 06:02 PM
User is offline View Users Profile Print this message

Author Icon
Calrissian
n00b

Posts: 6
Joined: 05/07/2009

It was Fusion that I used.  I did it two different ways, the first in normal boot mode, and the second in safe mode.  Initially, I was trying to fix the problem of the driver signature not being recognized, and neither way fixed that problem.  Then I noticed this Direct X 10 and 11 problem.  The dxdiag sections I included up there list what Turbine said was the problem, that although DirectX 11 is installed, the DDI Version is still showing as "9Ex."  They concluded that it was a bad or corrupted driver, or a problem of an old driver lingering on the system.

Like I said, I'll make a third go at it tonight, but I'm curious if anyone has either encountered this or has ideas of other things I can try.

Thanks to both of you for your help.

 11/02/2012 12:58 PM
User is offline View Users Profile Print this message

Author Icon
Calrissian
n00b

Posts: 6
Joined: 05/07/2009

I had success last night. I went back and uninstalled the driver again, and ran Fusion again (not in safe mode).  This time, though, I also uninstalled my monitor driver (Dell SP2309W).  After uninstalling, it just detected and ran the monitor using a generic driver.  That solved the DirectX 11 problem, and the game ran fine in 11.  I haven't tried running driver signature enforcement yet, but I'm not worried about that until I have something that needs it.

Thanks for everyone's help.  I just wanted to log this success in case someone else searches later with this problem.

 11/03/2012 03:09 PM
User is offline View Users Profile Print this message

Author Icon
Calrissian
n00b

Posts: 6
Joined: 05/07/2009

Spoke too soon.  On fresh boot this morning, the problem is back.  I've gone back and uninstalled and swept again.  This time, I've tried to install with ReadyDriverPlus uninstalled, which is the program I use to automatically disable driver signatures.  After installing the driver package, it doesn't detect the driver (this is as it has been).  The install says there are warnings, and the only warning is that it detects other hardware, which is an AMD device.  I assume this is the actual card I'm trying to install, since it doesn't recognize the driver for the 7850.

Back to square one.

Statistics
86369 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.