Topic Title: Drivers screwed above 12.6: WoW unplayable.
Topic Summary: Please read carefully!
Created On: 11/20/2012 05:27 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/20/2012 05:27 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 13
Joined: 11/20/2012

So I've just installed my new operating system, windows 8. _CLEAN INSTALL_ _All the latest drivers installed fine, no issues, problems during install, no errors. VGA drivers are latest 12.10 win8. My vga is Gigabyte HD6990.

And as I expected the drivers are just not going well unfortunately. WoW is totally sh!tting itself (pardon my french but this is the case).

Before I've upgraded to win8, I ran windows 7 with "old" 12.6 driver, because the rest wasn't working with WoW either. But I didn't really care since it was working nice on that driver. Tried all kind of settings, Disabled crossfire, tried 32bit and 64bit wow, changed to dx9/dx11 in wow graph settings, nothing helps.

But now I got no options, but to use this driver right? Should I try to downgrade my driver to 12.6 Win7 drivers?

The issue: Constant 20-30fps, terrible laggish movement, you do a 40degree turn and the screen is jittery and laggish like hell.

AMD! Something is VERY Wrong with your drivers above 12.6. And whats more interesting you don't even mention world of warcraft in the readme for the drivers above 12.6 at all! Are you aware of the issue at all? You really really broke something in the driver, page flipping or memory management, or whatever. But this means that since half a year your drivers aren't working properly on one of the most succesfull game that millions are playing -heck I would love to play it right now but can't-.

Have an ongoing open case with Blizzard and they confirmed that the issue is at the ATI drivers. I would like to get an official answer to this question please!

 11/21/2012 05:24 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 2
Joined: 11/21/2012

I am also having similar problems.  However my machine came with a driver after 12.6 that wouldn't even allow me to look at the screen or move due to the instability.  12.10 allows me to semi-play wow, but at a reduced frame rate that you are seeing with the same jitter during movement.

I had to change to Direct X9 as X11 was causing frequent lockups requiring a hard reboot.  So far... (a day) I have not had lockups with Direct X9, but my FPS are terrible, along with jitter.

I tried installing the 12.10 CAP1 application profiles, but they do not show up in Catalyst and I have not been able to find any information on how to access or select them, assuming there is one for WoW.

With system I should be screaming, but I am not getting more better performance than my 4 year old Asus running a single graphics card that was only so so in the day.  

Getting a resolution for playing WoW on the crossfire 7970 cards would be great.




Alienware M18X R2 running on Win 7 64bit

3rdGen Intel Core i7-3630QM (6MB cache up to 3.4Ghz w/Turbo Boost 2.0)

CrossfireX 2GB GDDR5 AMD Radeon HD 7970

750GB 7,200RPM SATA-II HDD + 32GB mSATA caching SSD

92815 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.