Topic Title: What is the dll for the auto-detect?
Topic Summary:
Created On: 11/27/2012 12:30 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 11/27/2012 12:30 AM
User is offline View Users Profile Print this message

Author Icon
ChronicFear
Peon

Posts: 5
Joined: 11/27/2012

Hello,

My computer is repeatedly crashing, and I suspect that it might be caused by my video driver.  I'm trying to install updates in Safe Mode (I changed the registry to allow MSIServer), but when I run the install package, it fails because it can't load the driver for the autodetect piece.  My issue is that I can't figure out which specific driver that is so that I can explicitly enable it in Safe Mode.  Does anyone on this forum know what it is?  Or is there a better way to do the install in Safe Mode?

Thanks!

 

Stats:

 

 

Graphics Card
Radeon HD5800

AMD Catalyst Driver Version, and Driver History
8.980.0.0

Operating System
Widows 7 64bit

Issue Details
Computer loads normally, but very slowly, then BSOD after 60-120 seconds.

CPU Details
Intel i7 8 core 2.93ghz

 11/27/2012 01:09 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7026
Joined: 11/13/2009

http://forums.amd.com/game/messageview.cfm?catid=444&threadid=162444&enterthread=y



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 11/27/2012 10:40 AM
User is offline View Users Profile Print this message

Author Icon
ChronicFear
Peon

Posts: 5
Joined: 11/27/2012

stumped,

 

Thanks for the link, however, I have done all of the things you suggest for a clean install, but I get hung up by the autodetect feature both during the uninstall and during the install.

For clarity, this is not the small autodetect program that tells me which driver package to download - this is whatever autodetect functionality is embedded within the driver installer itself.

I imaginge that ordinarily this would not be a problem, but since I'm running in Safe Mode, I suspect it's calling some service that I don't have disable - I just can't figure out what that service is so I can turn it on.

Any ideas?

Thanks,

Matt

 11/28/2012 06:47 PM
User is offline View Users Profile Print this message

Author Icon
ChronicFear
Peon

Posts: 5
Joined: 11/27/2012

I'm including the error message I am receiving for your reference.  Any additional help you can provide is greatly appreciated.

Thanks!

 

http://s11.postimage.org/y2ojq5ogz/Failed_to_load_detection_driver.png

 

 11/28/2012 07:34 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7026
Joined: 11/13/2009

This worries me (only because I don't know what it is) """ (I changed the registry to allow MSIServer) ""  Can you put it back to default? Do you have your anti-virus/ad blocker/malware blocker/zonealarm/keepawayfrommycomputeryoucommunistrat programs disabled during uninstall and install? Have you run Driver Fusion/Driver Sweeper (3.2.0) to remove anything AMD? Have you considered a System Restore?



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 11/29/2012 08:32 AM
User is offline View Users Profile Print this message

Author Icon
ChronicFear
Peon

Posts: 5
Joined: 11/27/2012

I can only survive a notmal boot for about 90 seconds, so I have to operate in safe mode, but safe mode disables windows installer by default.  All I did was turn that particular service back on so that I could try to install this driver. 

I do not have any antivirus running (and barely anything else, for that matter, since I'm in safe mode).  I am able to install and uninstall other drivers and programs, so I believe my issues is only related to the Catalyst install.  I suspect it's calling some service for the auto detect that is disabled by default unsafe mode, but I can't figure out what that service is so that I can enable it. 

 11/29/2012 08:34 AM
User is offline View Users Profile Print this message

Author Icon
ChronicFear
Peon

Posts: 5
Joined: 11/27/2012

I have run Driver Sweeper and have no remnants.  I'm trying to avoid a system restore if possible, but will go that route as a last result. 

Statistics
84100 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.