Topic Title: BSOD 7870 BF3
Topic Summary:
Created On: 12/09/2012 07:06 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/09/2012 07:06 PM
User is offline View Users Profile Print this message

Author Icon
Abundantcores
Peon

Posts: 4
Joined: 12/09/2012

I'm getting constand BSOD in BF3 with 12.11 Drivers.

 

Gigabyte 7870 WF3, at first i thought it was my overclock, on 12.8 it was running at 1175 / 1500 / 1.25v perfectly.

 

With 12.11 that just BSOD instantly, so i toned it down to 1150 / 1400 / 1.235v. it plays for 15 minuts and BSOD.

So i toned it down again to 1130 / 1400 / 1.218v (stock volts) and still BSOD.

 

Seems with 12.11 all i can do is run it at stock (1100 / 1200) yet i'm not even sure it will do that as i have not tested it extensivly.

 

Love the perfoemance off these drivers but it seems there is no overclocking with them.

 

Edit- i have just run it at stock, it lasted for 30 minuts at stock but still BSOD



Edited: 12/09/2012 at 08:36 PM by Abundantcores
 12/10/2012 06:07 AM
User is offline View Users Profile Print this message

Author Icon
MG11
Peon

Posts: 1
Joined: 12/10/2012

Could be a temperature issue.  I run two XFX 7870s (DD fans, but stock clocks) in crossfire.

The 12.7 and 12.11 betas are the only respectable drivers performance wise, but they have an issue of overheating in certain games, BF3 occasionally and Guild Wars 2 in particular (I could set my watch on the 29 minutes to BSOD just standing by the mystic forge in Lion's Arch).

I'm fairly certain the 95c+ temps observed before BSOD was the culprit.  The issue was the automatic fan speed control could never "catch up" to the heat generated.  By the time the fans went above 40%, temps were past critical.

My solution was to enable manual fan control on both cards and set it to 50% (tried 45%, not enough).

Temps are in line (rarely go above 80c) and the BSODs have gone away.

To test your heat in BF3, try the following:  run in windowed mode, as large a window as you can so you can observe the temps in CCC and change the fan % accordingly.  Find an unoccupied/low occupancy server running Caspian Border conquest.  Start on U.S. side and take the Apache.  Land at the gas station checkpoint (the one with the big flames).  Staying in the helicopter, press c to enable the external camera.  Between the particle effects of the environment flames, and the rotor draft, this will start stressing the card to 80-100% utilization and your temps will start going up dramatically.  Enable manual fan control and set to 50%.  Watch temps come down.  Gradually decrease the fan speed until the temps do not continue to climb.  You should be good after that.



-------------------------
 12/10/2012 09:17 AM
User is offline View Users Profile Print this message

Author Icon
Abundantcores
Peon

Posts: 4
Joined: 12/09/2012

Thanks for your reply.

I did that and it would not crash, I have MSI Afterburner OSD running and my temps never get over 57c

It randomly BSOD again 20 minuts in to a real game, temps were good.

I'm going to run 12.10 for a while, see how they are.

 

Originally posted by: MG11 Could be a temperature issue.  I run two XFX 7870s (DD fans, but stock clocks) in crossfire.

 

The 12.7 and 12.11 betas are the only respectable drivers performance wise, but they have an issue of overheating in certain games, BF3 occasionally and Guild Wars 2 in particular (I could set my watch on the 29 minutes to BSOD just standing by the mystic forge in Lion's Arch).

 

I'm fairly certain the 95c+ temps observed before BSOD was the culprit.  The issue was the automatic fan speed control could never "catch up" to the heat generated.  By the time the fans went above 40%, temps were past critical.

 

My solution was to enable manual fan control on both cards and set it to 50% (tried 45%, not enough).

 

Temps are in line (rarely go above 80c) and the BSODs have gone away.

 

To test your heat in BF3, try the following:  run in windowed mode, as large a window as you can so you can observe the temps in CCC and change the fan % accordingly.  Find an unoccupied/low occupancy server running Caspian Border conquest.  Start on U.S. side and take the Apache.  Land at the gas station checkpoint (the one with the big flames).  Staying in the helicopter, press c to enable the external camera.  Between the particle effects of the environment flames, and the rotor draft, this will start stressing the card to 80-100% utilization and your temps will start going up dramatically.  Enable manual fan control and set to 50%.  Watch temps come down.  Gradually decrease the fan speed until the temps do not continue to climb.  You should be good after that.

 

 12/12/2012 09:35 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7250
Joined: 11/13/2009

Have you disabled ULPS? You should. Google it.

Or > Go to registry and disable Ulps:

[HKEY_LOCAL_MACHINE\\SYSTEM\\ControlSet001\\Control \\Class\\{4D36E968-E325-11CE-BFC1-08002BE10318}]

and change "EnableUlps" to 0 under the 0000 and 0001 and 0003 keys.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

 12/12/2012 09:44 AM
User is offline View Users Profile Print this message

Author Icon
Abundantcores
Peon

Posts: 4
Joined: 12/09/2012

I fixed it.

It seems others had exactly the same problem on varius 7### series GPU's running 12.11 'BETA 11'

BETA 11 was the key here, those others switched back to BETA 8 and it cured the problem, i was advised to do the same and they were absolutly right.

Back on 12.11 BETA 8 and all is well.

I hope AMD are reading this, because whatever they did in BETA 11 vs BETA 8 they need to undo it, its a cause for BSOD and hard locks in BF3 for me and others.

Thanks for your help guys

 

Originally posted by: stumped Have you disabled ULPS? You should. Google it.

 

Or > Go to registry and disable Ulps: [HKEY_LOCAL_MACHINE\\SYSTEM\\ControlSet001\\Control \\Class\\{4D36E968-E325-11CE-BFC1-08002BE10318}] and change "EnableUlps" to 0 under the 0000 and 0001 and 0003 keys.

 

Statistics
85525 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.