Topic Title: Driver not working for 7950 on Windows 8 x64 bit
Topic Summary:
Created On: 12/27/2012 07:17 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/27/2012 07:17 PM
User is offline View Users Profile Print this message

Author Icon
Cberg
Peon

Posts: 2
Joined: 12/27/2012

Have just build a new machine.Connected 2 screens (DVI - 24", 1920x1200)On Win7 x64 everything works fine. I can install the catalyst software and enable Eyefinity. No problems at all.When going with Windows 8 x64 I can't install the Catalyst software without BSOD - or not quite BSOD - the machine shows random dots on the screen and then reboots.If I remove the Catalyst software and just go with the Windows 8 certified driver, (no catalyst, just the driver) it seems to work, but when shuting down the machine it crashes. Next time it starts up, I get and message saying recovered from unattended shutdown error...My machine specs are:XFXForce 7950 3GbIntel MB - DZ77BH-55K, I5 3570, 32 Gb Kingston Mem 1600 MHz(BIOS updated to newest from 17. Dec)Disk: Intel SSD, 2 x 330 (RAID, Striped)PSU: 750 WATTOS: Windows 8 Pro, x64Display, Samsung 24" and DELL 24"No overclocking, everything is standard out of the box.Temp inside machine is approx 21 degrees Celcius. CPU reports around 30.Have tried 12.11 Beta 11 driver both with or without .NET4Also 12.10, but same result.Actually I'm waiting for an active adaptor to arrive so I can connect the third monitor (same res. and size) so I really need to use Eyefinity.Please advise how to proceed, as I might have done something wrong, since this is my first ATI card. Thanks in advance,

-------------------------
 12/28/2012 06:15 AM
User is offline View Users Profile Print this message

Author Icon
Hardwood
Dungeon Master

Posts: 4001
Joined: 01/27/2008

It may or may not  help but grab .net 3.5, it includes all previous .net versions which many programs will need.



-------------------------

#1: Phenom II C2 955BE @ 3.6, Antec Kuhler 920, Gigabyte GA-MA790FX-DS5, Asus 5870/V2, ASUS Xonar D2X, 4 x 1gig OCZ2N1066SR2GK @800, Antec Truepower New 750, Arc Midi, Vistax64
#2: MSI A88X-G45, AMD A10-7850K, IGP, AMD 2x4GB 2133 (R938G2130UK), Antec 750 True, 128GB Sandisk SSD, WD Black 1TB, Win8.1pro x64
#3: Athlon 64 X2 4200+, AGP 1950pro, Audigy 2, Asus A8V-D, 2gig ram, Enermax 465P, Antec900case. Now on Win8.1pro cat 10.2

 12/28/2012 07:53 AM
User is offline View Users Profile Print this message

Author Icon
Cberg
Peon

Posts: 2
Joined: 12/27/2012

So it's actually possible to enable .NET 3.5 on Windows 8 from Control panel -> Turn Windows Features on/off.Read more here: http://www.microsoft.com/en-us/download/details.aspx?id=24872 After working around with things I was actually able install the Catalyst drivers/control center. However it did crash, but not during installation, but afterwards instead, making it still present after reboot. I'm now able to Setup eyefinity and use the Catalyst control center on Windows 8.I'm only running the 12.10 (non-beta) with no .NET included.Thanks!:-)

-------------------------
Statistics
83877 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.