Topic Title: Updated driver for Radeon HD 7570?
Topic Summary: Radeon 7570 driver
Created On: 12/28/2012 09:28 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 12/28/2012 09:28 AM
User is offline View Users Profile Print this message

Author Icon
GeorgeTasker
Peon

Posts: 1
Joined: 12/28/2012

I bought a new Dell XPS 8500 (Windows 7 Home Premium 64bit with SP1) that came with the AMD Radeon HD 7570.  The driver installed is v8.911.0.0 from October 25 2011.  

I'm trying to find an updated driver.  When I install the Catalyst package from the AMD site, it seems to install, no errors, but Windows Device Manager still shows the old driver.

When I try the AMD Driver Autodetect, it wells me "We were unable to find your product or OS".

Is it the 7570 that is not supported?  Or Win7 64bit?  I've seen dozens of others looking for driver updates for this card, but searching the AMD site and he AMD forums there is not one reference to "7570", so I'm not sure what to do or where to look.

 12/28/2012 11:17 AM
User is offline View Users Profile Print this message

Author Icon
Canis-X
Forum Moderator

Posts: 719
Joined: 08/28/2012

Try downloading and installing Driver Fusion then uninstalling CCC in the control panel.  Reboot into safe mode and run Driver Fusion with elevated priveleges.  Select AMD Graphis then clean.  Reboot when prompted into your normal OS.....You should download the current CCC suite as shown below.  You can choose to only install the driver instead of the full suite if you want.



-------------------------

The opinions expressed above do not represent those of Advanced Micro Devices or any of their affiliates.
Requiescat In Pace AMD Processor Forums | Member since: 1/19/2009 | Post count:
4142
Please don't PM me with questions, instead create a thread so that everyone can assist and benefit from the knowledge provided. Thanks in advance!

 01/06/2013 12:36 AM
User is offline View Users Profile Print this message

Author Icon
wlennon
Peon

Posts: 2
Joined: 01/06/2013

That's the problem. The official drivers downloaded from AMD.com do not contain an entry for this AMD graphics card.

The card is an AMD Radeon HD 7570, and its full hardware ID is PCI\VEN_1002&DEV_675D&SUBSYS_2B221028&REV_00 .

Although the driver files contain entries for 3 other HD 7570's (entries # AMD6759.1,AMD6759.3,AMD675D.1), they're missing an entry for this particular subsys. All of the other 7570s use identical drivers (which, incidentally, is the same as for the 6570s),  and this issue could be resolved as easily as adding two lines to the INF file:

"%AMD675D.2%" = ati2mtag_NI, PCI\VEN_1002&DEV_675D&SUBSYS_2B221028 (or even PCI\VEN_1002&DEV_675D)

and

AMD675D.2= "AMD Radeon HD 7570"

Alternatively, they could remove the "&SUBSYS_300017AF" from entry AMD675D.1, to the same effect.

 01/06/2013 03:00 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7273
Joined: 11/13/2009

Have you tried this? http://forums.amd.com/game/messageview.cfm?catid=444&threadid=162109&enterthread=y

and this ? http://forums.amd.com/game/messageview.cfm?catid=444&threadid=162444&enterthread=y



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

 01/06/2013 04:29 PM
User is offline View Users Profile Print this message

Author Icon
wlennon
Peon

Posts: 2
Joined: 01/06/2013

If you're referring to the .NET framework (4.0 or 4.5), yes I already have it installed. That's not the problem.

The problem is that the official AMD graphics drivers (posted at www.amd.com or game.amd.com ) do not contain the correct hardware ID for the AMD Radeon HD 7570 that is included with Dell XPS 8500 and Dell Vostro 470 desktops. You can check the INF files yourself, if you don't believe me. There is no entry for "PCI\DEV_1002&VEN_675D&SUBSYS_2B221028", or any compatible hardware ID. This is true for every official release up to, and including the latest 12.11b11 drivers.

Because the 223 MB driver installation package does not contain information about my AMD graphics hardware, it doesn't matter how many times I rerun Driver Fusion, Driver Sweeper, or any similar program, or how many times I reinstall .NET 4 or 4.5; the net result will be the same.

What is needed is for AMD to add two lines to their INF files, and sign those drivers by providing a new catalog file. This could easily be done at the next driver update, with a negligible amount of effort on AMD's end.

Statistics
86399 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.