Topic Title: Catalyst Control Center Can't Find My Card.
Topic Summary: CCC no longer works after updating
Created On: 01/12/2013 01:28 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 01/12/2013 01:28 PM
User is offline View Users Profile Print this message

Author Icon
jmi0920
Peon

Posts: 4
Joined: 01/12/2013

 

I Installed a driver update for my display driver and ever since then I get this message on startup: "No AMD graphics driver is installed, or the AMD driver is not functioning properly. Please install the AMD driver appropriate for your AMD hardware."

I have a Radeon HD 7770 so I'm unsure why i'm getting this message, any help is appriciated.

Graphics Card
 AMD Radeon HD7770 2GB
 No Over clocking.

AMD Catalyst Driver Version, and Driver History
Unknown. Tried most recent update. Was using the version that came shipped with my computer.


Operating System
Windows 7 64 bit

Issue Details
Get the message about it not finding my graphics card, also have an issue where sometimes I get the message about it saying my display driver has stopped working and that it has recovered. I think this is causing an issue with DCS: A-10C and it constantly freezing.



Motherboard or System Make & Model
Gateway FX6860-UR21P

Power Supply

Unknown

Display Device(s) and Connection(s) Used
DVI

Applications and Games

DCS: A-10C

Chrome (rarely)

CPU Details
Intel i7 3770

Motherboard BIOS Version
Unknown

System Memory Type & Amount
8GB DDR



 



Edited: 01/12/2013 at 01:43 PM by jmi0920
 01/12/2013 01:43 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Stack Smasher

Posts: 6082
Joined: 11/13/2009

http://forums.amd.com/game/messageview.cfm?catid=444&threadid=162109&enterthread=y



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit *Gateway HD2401 24" 2ms 1920x1200  ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit  



* A clear conscience is usually a sign of bad memory *

 01/12/2013 01:56 PM
User is offline View Users Profile Print this message

Author Icon
jmi0920
Peon

Posts: 4
Joined: 01/12/2013

Installed .NET Framework 4.5 and restared my computer. Still getting the same error message about it not finding my card.

 01/12/2013 02:04 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Stack Smasher

Posts: 6082
Joined: 11/13/2009

You have to install the drivers after you install the netframeworks. Follow this > http://forums.amd.com/game/messageview.cfm?catid=444&threadid=162444&enterthread=y



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit *Gateway HD2401 24" 2ms 1920x1200  ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit  



* A clear conscience is usually a sign of bad memory *

 01/12/2013 02:16 PM
User is offline View Users Profile Print this message

Author Icon
jmi0920
Peon

Posts: 4
Joined: 01/12/2013

My bad, going with a fresh install to be safe, deleted the install manager and I'm on the part with Driver Sweeper. You say to delete "AMD Graphics", I don't have that but I have "AMD Display" is that safe to delete?

 

 01/12/2013 02:38 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Stack Smasher

Posts: 6082
Joined: 11/13/2009

Yes.....same thing.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit *Gateway HD2401 24" 2ms 1920x1200  ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit  



* A clear conscience is usually a sign of bad memory *

 01/12/2013 02:46 PM
User is offline View Users Profile Print this message

Author Icon
jmi0920
Peon

Posts: 4
Joined: 01/12/2013

Still no luck, during the install I got an error about it needing a digitally signed driver about two items, I didn't get to read them fully.

EDit: Went to device manager to look at my card, I noticed there is a yellow triangle on it with an exclamation point, Clicked on it and got:

"Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)

Edit of the Edit: Updated driver from there to fix the card and reran th catalyst installer. CCC just won't open (no error, just not open) and neither will my steam games.

 



Edited: 01/12/2013 at 03:07 PM by jmi0920
Statistics
80933 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.