Topic Title: Found problem with AMD AHCI Driver - Windows 8 freeze after wakeup from standby (cursor still movable)
Topic Summary:
Created On: 01/17/2013 05:30 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 01/17/2013 05:30 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 01/17/2013

I found a Problem with AMD AHCI Driver. I found a workaround. Maybe my information helps somehow to fix this.


I built two identical rigs containing:

APU: A8 5500 FM2
Mainboard: Asus F2A55-M LK
HD: Samsung SSD 830 128GB
OS: Windows 8 Pro 64-bit

On wakeup from standby for a few seconds everything is ok. Then the complete system freezes, but the mouse. I can still move the cursor, but when i click somehting nothing happens. After a few minutes the mouse sometimes freezes, too. Ctrl-Alt-Del has no effect. The only thing i can do is hit the reset-button. Then Windows 8 does something like a quick reboot and the Desktop shows up like it was when it freezed. I have to hit reset-button again and Windows 8 does a full boot and everything is ok until i use standby-functionality of windows 8. For example when System goes to standby because of Idle-Time i cannot wake these systems up by moving the mouse without the described problem.

what i tried:
...i tried everything. My first thought was graphics-driver I deinstalled / reinstalled AMD Stuff. Tried multiple Versions. I even used the Catalyst complete-uninstall option. I checked the windows event-history but the only entries i found was something like "the system rebootet after an unexpected shutdown" (my System-Language is german, so i don´t exactly know what the english message is). I tried slight over-voltage in Bios. Messed with Energy-Settings, Bios-CPU-Settings... even Windows 8 Reinstalls. I didn´t found much usefull information about my problem. The Posts i found pointed all to graphics-driver for beeing the problem. ...then, i found something where someone had a problem with AMD- Harddisk-Drivers. An old post from the early days of Windows 8 ConsumerPreview. But this became my new direction....

how i finally fixed this:
My OS was just cleaned by Catalyst-complete-Uninstall Prozess. But in Device-Manager i still found the AMD AHCI Driver provided by AMD. I used the driver-update feature and instead of automatic update i went to  "search by list" and had two entries. AMD AHCI and Microsoft Generic AHCI. I switched to the Microsoft driver and since then everything is ok.

 01/17/2013 07:08 AM
User is offline View Users Profile Print this message

Author Icon
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

You're supposed to use the AHCI driver provided by the manufacturer of your motherboard. I don't even know why AMD provides a generic driver on their website. Peole are not supposed to use it.


CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

93090 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.