Topic Title: USB 3.0 drivers on Whs2011 or Server 2008r2
Topic Summary:
Created On: 01/25/2013 06:06 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 01/25/2013 06:06 PM
User is offline View Users Profile Print this message

Author Icon
mika91
Peon

Posts: 4
Joined: 03/11/2011

Hi,

I ordered a gigabyte GA-F2A785XM-D3H board with native AMD usb 3.0 ports, and I can't install drivers for them!

In the device manager, there are two unknown Universal "Serial Bus (USB) Controller" with PID VEN_1022&DEV_7812.
This is the ID for native AMD USB3.0 host controller (confirmed by the gigabyte hotline)

I tried gigabyte installation disk, online drivers, then AMD chipsets drivers... nothing works! 

Finally, I tried to manualy add the driver, using C:\AMD\Support\13-1_vista_win7_win8_32-64_sb\Packages\Drivers\SBDrv\hseries\USB30\W764A\amdxhc.inf file but I got an error:" The folder you specified doesn't contain a software compatible.....make sure it is designed to word with windows x64-based system".
I tested all the folders in the USB3.0 directory, even moving the amdxhc.sys in the same level folder as *.inf file (as I read in some MSI forums)

Is there anyway to make usb ports work in whs2011 or Server 2008r2?
Are they compatible with SBS essential 2012?
Thanks 

 01/25/2013 06:14 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4847
Joined: 12/27/2008

Server operating systems are not supported by AMD. I suggest you try modding the drivers yourself, maybe you can add support for installation, and they might work if they are binary compatible.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 01/25/2013 06:24 PM
User is offline View Users Profile Print this message

Author Icon
mika91
Peon

Posts: 4
Joined: 03/11/2011

Modding the driver?

 01/25/2013 07:39 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4847
Joined: 12/27/2008

Originally posted by: mika91 Modding the driver?

 

By modding I mean you open the installation file (.inf) in the package with a text editor and change parameters to what your OS would accept.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 01/26/2013 12:52 AM
User is offline View Users Profile Print this message

Author Icon
mika91
Peon

Posts: 4
Joined: 03/11/2011

Originally posted by: Eydee
Originally posted by: mika91 Modding the driver?

 

 

 

 

By modding I mean you open the installation file (.inf) in the package with a text editor and change parameters to what your OS would accept.

 

Do you have any guide or tutorial?

 01/26/2013 01:12 AM
User is offline View Users Profile Print this message

Author Icon
mika91
Peon

Posts: 4
Joined: 03/11/2011

Ok.
Just googled and found I have to replace NTamd64.6.1.1 with NTamd64.6.1!

Now my drivers are installed!  
I'll test them as soon as possible! 

Statistics
84268 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.