Topic Title: Driver download link isn't working?
Topic Summary:
Created On: 02/07/2013 11:35 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/07/2013 11:35 AM
User is offline View Users Profile Print this message

Author Icon
Blebekblebek
Peon

Posts: 8
Joined: 03/30/2008

http://www2.ati.com/drivers/13-1_vista_win7_win8_64_dd_ccc_whql.exe

is not working, I've tried to remote upload to freehost but it also failed, so I don't think it's my internet problem.

I've just purchased HD 6670

and I need new driver

is there any other place to download new driver?

 

Thank you.



-------------------------

What?

 02/07/2013 11:39 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7467
Joined: 11/13/2009

Here > http://benchmark3d.com/amd-catalyst-13-1-whql-legacy



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 


 


 *  Quando Omni Flunkus, Moritati *

 02/07/2013 12:24 PM
User is offline View Users Profile Print this message

Author Icon
it.tbush
Peon

Posts: 7
Joined: 02/07/2013

Yea, The link is currently down. I am needing to get CCC, so I can get drivers for my HD 4800. Any idea on where else I can download CCC?

 

Here is the link I am trying to access.

 

www2.ati.com/drivers/legacy/13-1legacy_vista_win7_win8_64_dd_ccc.exe

 02/07/2013 12:30 PM
User is offline View Users Profile Print this message

Author Icon
Blebekblebek
Peon

Posts: 8
Joined: 03/30/2008

Originally posted by: stumped Here > http://benchmark3d.com/amd-catalyst-13-1-whql-legacy

 

that page also redirect drivers file to ati server.



-------------------------

What?

 02/07/2013 12:36 PM
User is offline View Users Profile Print this message

Author Icon
it.tbush
Peon

Posts: 7
Joined: 02/07/2013

Originally posted by: Blebekblebek
Originally posted by: stumped Here > http://benchmark3d.com/amd-catalyst-13-1-whql-legacy

 

 

 

that page also redirect drivers file to ati server.

 

Yea that link is not working either. It must be AMD's server. Only reason I say that, is because it seems multiple links are not working.

 02/07/2013 12:41 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7467
Joined: 11/13/2009

Originally posted by: Blebekblebek
Originally posted by: stumped Here > http://benchmark3d.com/amd-catalyst-13-1-whql-legacy

 

that page also redirect drivers file to ati server.

Edit: Sorry that was the Legacy drivers...Here's what you need (i just tried it...no redirect

http://benchmark3d.com/amd-catalyst-13-1-whql



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 


 


 *  Quando Omni Flunkus, Moritati *

 02/07/2013 12:42 PM
User is offline View Users Profile Print this message

Author Icon
Blebekblebek
Peon

Posts: 8
Joined: 03/30/2008

oh well, I guess I'll stop for now, it's midnight already here.

I hope it's going back in the morning. Good Night.



-------------------------

What?

 02/07/2013 12:46 PM
User is offline View Users Profile Print this message

Author Icon
it.tbush
Peon

Posts: 7
Joined: 02/07/2013

Link is working now, must of been server maintenance or something. Thanks for the info

 02/07/2013 12:55 PM
User is offline View Users Profile Print this message

Author Icon
it.tbush
Peon

Posts: 7
Joined: 02/07/2013

Nevermind, Link is still broke. Downloaded the driver boost thinking it was CCC. All I want to do is Download CCC and update and I still cant.

 02/07/2013 01:00 PM
User is offline View Users Profile Print this message

Author Icon
it.tbush
Peon

Posts: 7
Joined: 02/07/2013

Here is driver page

support.amd.com/us/gpudownload/windows/legacy/Pages/legacy-radeonaiw-vista64.aspx

 

Here is what the Link it prompts

www2.ati.com/drivesr/legacy/13-1-legacy_vista_win7_win8_64_dd_ccc.exe

 02/07/2013 01:05 PM
User is offline View Users Profile Print this message

Author Icon
it.tbush
Peon

Posts: 7
Joined: 02/07/2013

http://gyazo.com/7268bb1c92d100f1271023138e9cac5c

 

This link shows what message i am getting from google chrome

 02/07/2013 01:41 PM
User is offline View Users Profile Print this message

Author Icon
paks1969
Peon

Posts: 1
Joined: 02/07/2013

That link redirects also, if you click on the download button you get a 404 error.

 02/07/2013 02:06 PM
User is offline View Users Profile Print this message

Author Icon
it.tbush
Peon

Posts: 7
Joined: 02/07/2013

Link is still down, Not sure what is going on. Either the link is bad, or the file path is incorrect. I think it has something to do server side.

 02/07/2013 03:32 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7467
Joined: 11/13/2009

I have no problem downloading the drivers now..or when you first complained about it. What country are you in?? The link I furnished you works...when you click the link it gives you two options..open or save. I hope you are choosing save. There is no problem with the links.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 


 


 *  Quando Omni Flunkus, Moritati *

 02/07/2013 03:33 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7467
Joined: 11/13/2009

Originally posted by: it.tbush Nevermind, Link is still broke. Downloaded the driver boost thinking it was CCC. All I want to do is Download CCC and update and I still cant.

You must have a virus redirecting you...driver boost?!!!!



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 


 


 *  Quando Omni Flunkus, Moritati *

 02/07/2013 09:13 PM
User is offline View Users Profile Print this message

Author Icon
Blebekblebek
Peon

Posts: 8
Joined: 03/30/2008

it's fine now, phew glad I didn't wait for it.

 

it's server down I believe

I can't even open ati.com last night.

 

Thank you.



-------------------------

What?

Statistics
87587 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.