Topic Title: Display Driver and HDMI Audio Driver Fail to Install
Topic Summary:
Created On: 02/14/2013 04:54 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 02/14/2013 04:54 PM
User is offline View Users Profile Print this message

Author Icon
rrockw
Peon

Posts: 3
Joined: 02/14/2013

 

Graphics Card
- ATI Radeon HD 5670
- No overclocking

AMD Catalyst Driver Version, and Driver History
- Tried to install latest release version, 13-1_vista_win7_win8_64_dd_ccc_whql

Operating System
- Windows 7 64-bit; Service Pack 1


Issue Details

I followed the directions in the link below to install the new version of the software.  Not sure which version I had before but I had installed it sometime in 2011.  http://forums.amd.com/game/messageview.cfm?catid=444&threadid=162444&enterthread=y

When I was on the step to reinstall the drivers that I had advised me their were warning in my install:

AMD Display Driver 9.012.000  Failed

HDMI Audio Driver 9.012.000 Failed

Error:

Driver Install:  Windows version does not support this operation (was repeated 4 times)

 

When I restarted the system after the final step from the link above and looked at the device driver it had a yellow square and clicking on it revealed this message:

Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)

I tried installing manually by pointing it to the newly installed directory but it just says the installed version is the latest one.

 

-Motherboard or System Make & Model

- DELL Studio XPS 8100

Power Supply

 n/A


CPU Details
- Intel Core (TM) i5 CPU 650 @ 3.20GHz
- No overlooking


Motherboard BIOS Version
- the BIOS version is displayed as soon as your system is powered on (ex: ASUS BIOS 1015)

System Memory Type & Amount

8GB

 

Any help on this issue would be greatly appreciated.

 

Rich

 



Edited: 02/14/2013 at 05:03 PM by rrockw
 02/15/2013 01:13 PM
User is offline View Users Profile Print this message

Author Icon
rrockw
Peon

Posts: 3
Joined: 02/14/2013

I called tech support and they advised to try installing the 12.10 drivers.  I'll do that and report back.

 02/15/2013 02:29 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7171
Joined: 11/13/2009

You can always try a clean install http://forums.amd.com/game/messageview.cfm?catid=444&threadid=162444&enterthread=y



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 02/15/2013 03:33 PM
User is offline View Users Profile Print this message

Author Icon
rrockw
Peon

Posts: 3
Joined: 02/14/2013

Thanks Stumped. I mentioned in my original post that I had used that exact link to perform a clean install.

 

I did install the 12.10 driver and did what the tech recommeded - i.e. using the AMD unistall program.  Rebooted and installed the old drivers but still had the AMD Driver Fail to install.

 

Called tech support again and went through the process with them and were unable to resolve the issue.  They seem to think that the issue may lie with my card being a Dell OEM amd card.   Dell gave me links to old drivers so at this points it looks like I'm out of luck.

Statistics
84704 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.