Topic Title: Drivers for new 7790 cards?
Topic Summary: You'd think they'd release a driver to support the card...
Created On: 04/10/2013 03:33 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 04/10/2013 03:33 AM
User is offline View Users Profile Print this message

Author Icon
bsim500
Peon

Posts: 2
Joined: 04/10/2013

Hi, I just bought a new Asus HD 7790 card. The newest official release 13.1 and the 13.3 Beta 3 drivers do not detect the card. They install the HDMI audio driver, but not the actual graphics drivers. The driver disk that came with the card does work but seems to be a remarkably old version of "12.101.2-130215a-153805C-Asus".

Q: When can we see a proper 13.x release driver that supports the card? Didn't this happen before when AMD released a card but no official drivers for it?

 04/11/2013 11:37 AM
User is offline View Users Profile Print this message

Author Icon
guyjeb
Peon

Posts: 2
Joined: 04/11/2013

I have the exact same Problem.  We purchased 4 Dell Optiplex 3010's that had ATI Radeon HD 7570's. The Current 13.1 CCC Suite '13-1_vista_win7_win8_64_dd_ccc_whql' does not install the drivers for this Card, only the HD Audio, SDK runtime, and ATI Install manager.

 

I found the Repository of Previous Drivers:

http://support.amd.com/us/gpudownload/windows/previous/Pages/radeonaiw_vista64.aspx

 

Thanks

-GuyJeb



Edited: 04/11/2013 at 01:23 PM by guyjeb
 04/11/2013 05:11 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

Originally posted by: bsim500 Didn't this happen before when AMD released a card but no official drivers for it?

 

It happens every time, but there's always a driver on the CD that works. Everyone can live with it for a month or two.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 04/12/2013 11:30 AM
User is offline View Users Profile Print this message

Author Icon
guyjeb
Peon

Posts: 2
Joined: 04/11/2013

 

It happens every time, but there's always a driver on the CD that works. Everyone can live with it for a month or two.

I found 'working' drivers on the Dell Driver download page. however the CCC Suite version is stating version 3.0... 0.o



Edited: 04/12/2013 at 07:42 PM by guyjeb
 04/12/2013 06:48 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

Originally posted by: guyjeb Now if I could just find the drivers that were on the CD, had we bought the card retail. Buying through dell means no disc other than the "Dell Drivers and Utilities" disc.

 

Did you buy a computer or just a video card?



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

Statistics
88969 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.