Topic Title: problem with Radeon HD 5450 driver and compatability with Premiere Elements 10
Topic Summary: Radeon HD 5450 driver
Created On: 04/11/2013 11:51 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 04/11/2013 11:51 AM
User is offline View Users Profile Print this message

Author Icon
fishmor
Peon

Posts: 1
Joined: 04/11/2013

About a month ago, I started getting the message that I had an incompatible display driver when I loaded premiere elements 10.  I came to this website, downloaded the latest driver, and it still hasn't worked.  I also tried the beta driver.  I have been down for about 3 weeks now and I need to get back up and running.  For some reason, premiere elements version 8 works fine.  Here are some of my specs:

HP Pavillion Elite 210y PC

AMD PHenom II 945 quadcore processor

graphics card is above, Radeon HD 5450

Windows 7, 64 bit

 

Thanks, Eric

 

 04/11/2013 05:09 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Dungeon Master

Posts: 4282
Joined: 12/27/2008

If everything else works, it must be a faulty driver detection algorhythm in the program. Contact Adobe and ask them (if you have a legit version of the application).



-------------------------

CPU: AMD Phenom II X4 810 @ 3250MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 850/1150MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 7 Pro x64

CPU: Pentium 4 Northwood S478 @ 3200MHz | RAM: 1,5GB DDR 400| MoBo: Gigabyte GA-8S661FXMP-RZ | GPU: ASUS Radeon X1650 Pro 256MB | Display: Dimarson 19" CRT | PSU: Noname 400W | OS: changing twice every week...

Statistics
80998 users are registered to the AMD Support and Game forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.