Topic Title: GPU Conflict (6670 and 4850)
Topic Summary: Not trying to Xfire
Created On: 04/16/2013 06:01 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 04/16/2013 06:01 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 4
Joined: 04/15/2013

I have a ATI Radeon 4850 and 6670. Both are recognized in the catalyst control center, altough it says "Disabled Adapter" for the card I do not boot into windows with the monitor attached to it (ie. Depending on which card the monitor is plugged into when I boot, it will run that card). Device manager shows both cards plugged in, and operating correctly with the drivers. I have tried booting with one monitor on each card to no avail. 

I have read that you can run two seperate monitors from two different cards, but it is not allowing me to do this. Again, both cards work if the monitor is attached to one or the other card. 

I am trying to fix this issue so I can solve my main problem which is I cannot get the secondary card (whichever it may be) to mine bitcoins unless the other one is disabled in device manager (only one card works at a time, if both are enabled, there seems to be conflicts).

 04/16/2013 06:22 PM
User is offline View Users Profile Print this message

Author Icon
QB the Slayer
Master Looter

Posts: 346
Joined: 11/27/2012

Why would you ever want to have two very different descrete GPU's...  it is mind boggling why you would even attempt such a thing.





CPU: AMD FX-8350.||.Cooler: Corsair H80i
MB: Gigabyte 990FXA-UD7.||.RAM: 8 GB Mushkin Blackline DDR3 2000MHz (7-10-8-27-1T)
Case: CoolerMaster HAF 932.||.PSU: Corsair HX750
GPU:Asus R9 270X DirectCU II TOP.||.Audio: Creative X-Fi Titanium Fatal1ty Pro w/ Logitech Z-5300e (5.1, 280W-RMS)
System Drive: 2xSamsung 840 Pro 128GB RAID0.||.Working Drive: 2xMushkin Chronos 60GB RAID0

 04/16/2013 08:24 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 4
Joined: 04/15/2013

Found solution.

Found the issue.  The new version of openCL conflicted with the 4850 for some reason.  And by the way,  with both cards, I am running a significantly faster FPS.  So the guy before me can keep his opinions to himself.  

The steps I took to fix that were:

1. Check out files named amdocl64.dll, amdsc64.dll and OpenCL.dll (in C:\Windows\system32) and amdocl.dll, amdsc.dll and OpenCL.dll (in C:\Windows\SysWOW64). If they don’t have the same date, they are likely the cause of the problem: it seems that the AMD APP SDK Runtime installer/uninstaller has trouble updating/removing them, so you end up with some from a version and some from another version, which just isn’t able to work.

2. Uninstall the AMD APP SDK Runtime, for me I ran setup.exe in

3. delete any of the remaining files spotted in 1. that may be left in system32 and SysWOW64

4. reinstall the AMD APP SDK Runtime.  I installed an older version.
AMD-APP-SDK-v2.5-Windows-641  (v2.8 had the same issues)

5. reboot, I didn't need to but it might help. 

93420 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.