Topic Title: Can not enable OpenCL for Gigabyte HD 7850 card
Topic Summary:
Created On: 05/01/2013 04:50 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/01/2013 04:50 PM
User is offline View Users Profile Print this message

Author Icon
Oldgamer
Peon

Posts: 1
Joined: 05/01/2013

I installed the latest ATI SDK (2.8) and it did not help. GPU Caps Viewer shows that OpenCL is not supported.

Catalyst Control Center does not show OpenCL in information center.

I tried different versions of CC, same result.

Windows XP SP2

Motherboard: ASrock E35LM1 (with A-240 processor)

 

Other info:

Driver Packagin Version: 8.961

Catalyst version 12.4

2d driver 6.14.10.7261

Direct3D version 6.14.10.0903

OpenGL version 6.14.10.11631

Catalyst Control Center 2012.0405.2154.37503

Please help!

Thank you in advance.

 

 

 05/02/2013 12:09 AM
User is offline View Users Profile Print this message

Author Icon
Eydee
Dungeon Master

Posts: 4276
Joined: 12/27/2008

As far as I know XP is not supported for OpenCL. XP SP2 is even less supported,  MS dropped support for it in 2010.



-------------------------

CPU: AMD Phenom II X4 810 @ 3250MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 850/1150MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 7 Pro x64

CPU: Pentium 4 Northwood S478 @ 3200MHz | RAM: 1,5GB DDR 400| MoBo: Gigabyte GA-8S661FXMP-RZ | GPU: ASUS Radeon X1650 Pro 256MB | Display: Dimarson 19" CRT | PSU: Noname 400W | OS: changing twice every week...

 05/03/2013 02:33 PM
User is offline View Users Profile Print this message

Author Icon
Claggy
Peon

Posts: 9
Joined: 05/26/2011

AMD has decrepiated OpenCL support for XP from APP SDK 2.5, the last driver you can use and still have OpenCL support is Cat 12.1

http://www.hal6000.com/seti/boinc_ati_gpu_cheat_sheet.htm

Downgrading to an earlier driver can be difficult, the Catalyst Uninstaller leaves it's files behind in the System32 and SysWOW64 directories, and older Catalyst Installers won't overwrite newer files, while i managed to get AMD to release an uninstall utility for Windows 7, a utility for other OS's is proving elusive:

http://devgurus.amd.com/thread/160303

So once you're uninstalled the Catalyst drivers, you'll need to remove the files mentioned manually, reboot, then install the older driver.

Claggy



-------------------------


Edited: 05/03/2013 at 02:50 PM by Claggy
 05/03/2013 07:17 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Stack Smasher

Posts: 6091
Joined: 11/13/2009

...or just follow the "clean install guide" which is found in the "How-to and FAQ" section.

http://forums.amd.com/game/messageview.cfm?catid=444&threadid=162444&enterthread=y



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit *Gateway HD2401 24" 2ms 1920x1200  ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit  



* A clear conscience is usually a sign of bad memory *

Statistics
80976 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.