Topic Title: hd6570 reolution not displaying correctly
Topic Summary: problem with 1920x1080 output
Created On: 05/05/2013 07:25 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/05/2013 07:25 AM
User is offline View Users Profile Print this message

Author Icon
allio
Peon

Posts: 2
Joined: 05/05/2013

bought a new 6570 to install in Dimension 5150 running with 2.5gb 533mhz ddr2, and ssd. Using latest catalyst and drivers. Monitor Logik FullHD 1080p L24DVDB19 tv on VGA and HDMI. Windows 7 Ultimate SP1.

After installation, the new card won't correctly detect a 1920x1080 display as available. Maximum working resolution 1440x900. When I turn off EDID in catalyst, and force 1920x1080 60hz, I get a visible display but lose a considerable portion of the left of my desktop as if to an extended display.

When I remove the card and run my Integrated graphics Intel 82945g, it detects the 1920x1080 display available and scales and displays correctly.

Also the card won't output HDMI, (or my TV won't detect any output). Whe I connect the HDMI and VGA at the same time nothing happens. Catalyst does not detect any difference.

 05/06/2013 09:06 AM
User is offline View Users Profile Print this message

Author Icon
allio
Peon

Posts: 2
Joined: 05/05/2013

anybody?

Statistics
88766 users are registered to the AMD Support and Game forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.