Topic Title: FPS Issues after update from 12.10 to 13.4
Topic Summary: Every game has fps issues now (Dota 2, CSGO, etc.) HD6970
Created On: 05/13/2013 09:13 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 05/13/2013 09:13 AM
User is offline View Users Profile Print this message

Author Icon
funkyforest
Peon

Posts: 1
Joined: 05/13/2013

Updated my CCC from 12.10 to 13.4, Express install when updating. Everything was working fine and running high fps before updating, but now after update fps is low and drops frequently.

I have not changed any settings in CCC, they're all on default like before.

I have tried rolling back to 12.10 after uninstalling all drivers and CCC, but all programs end up not responding (skype, etc.), I even can't load any pages on google chrome.

And help is appreciated! thanks!

 05/13/2013 10:37 AM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7171
Joined: 11/13/2009

Why were you updating your card? 12.10 to 13.4 is quite a update...have you updated to the required netframework level? Please supply some info:

Please read the sticky "Read Before Posting".
http://forums.amd.com/game/messageview.cfm?catid=440&threadid=160417&enterthread=y

We need to know:

1. Processor (I5-xxxx, A10-xxxx, etc)
2. Graphics card (HD6970, HD4850, Mobility, etc)
3. OS (Win7, Win8, WinXP, 32 or 64bit, etc)
4. Driver version (13.2, 12.10, etc)
5. Power Supply..list make and model and wattage
6. RAM
7. Did your computer come with the OS and Graphics card you have now?
8. Monitor resolution (native), connected by (DVI, HDMI, etc)


If this is a LAPTOP, list your laptop model number and please post in the correct forum...that would be the laptop forum   http://forums.amd.com/game/categories.cfm?catid=448&entercat=y


If your issue is resolved, be a helpful forum user and report back the steps that you used. It will help other users.

 



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 * A clear conscience is usually a sign of bad memory *

 05/16/2013 10:10 AM
User is offline View Users Profile Print this message

Author Icon
Destroyer
Peon

Posts: 2
Joined: 05/16/2013

Hi, I have the same problem. I was first using 12.10 and everything was fine but than I installed 13.1 and in all my games i started to get low fps. I have AMD A8 3870k APU crossfired with HD6670. I installed 13.4 and everything is same. When playing Assassins Creed Revelations I barely get 30 FPS and one guy on You Tube was playing with same CPU (without HD6670) and he gets 30-50 FPS. Also other games have low FPS, for example Call of Duty 2 lags if I turn on anti aliasing and Splinter Cell Conviction lags in main menu (in game i get min 15fps and max 25fps) I have tried to uninstall 13.4 and install 12.10 games work better but windows explorer and some other programs crash.

 05/18/2013 03:43 PM
User is offline View Users Profile Print this message

Author Icon
JMcQuade
Peon

Posts: 5
Joined: 04/24/2013

Hi, I had the same problem and the only solution is to install V 12.8.AMD Catalyst uses Un-install Utility to remove the ones you have.only supports win7http://support.amd.com/us/gpudownload/windows/Pages/catalyst-uninstall-utility.aspxfor other versions of Windows can use Driver Sweeper

Edited: 05/18/2013 at 03:52 PM by JMcQuade
 05/21/2013 12:05 PM
User is offline View Users Profile Print this message

Author Icon
MrDimn
Peon

Posts: 7
Joined: 05/17/2013

Greetings - 

 

I am in the same boat.  I also went from 12.10 to 13.4.  

Yes, it is a big jump but I thought it might be time to make the change to the newer drivers.

 

With my games, I am seeing video flickering and FPS issues and the only thing I changed was my video driver.

 

My system info is as follows:

 

1) i7 980X

2) ATI 5970

3) Win 7 - 64 bit

4) Now: 13.4 - previously: 12.10

5) Not sure of Power Supply, but it's 1000 W.

6) 12 GB Patriot RAM

7) Yes.  I built the system myself, and I have only added hard drives over time. But that was way before I made the change.

8) Monitor: LG E2350 1920x1200

 

Any and all info is appreciated.

 

 

Doug

 05/23/2013 02:14 PM
User is offline View Users Profile Print this message

Author Icon
RQuallsJR
Nerfed

Posts: 55
Joined: 05/19/2012

You must be up to date with your .net framework. goto windows update and download all updates. Not saying it will fix all of your problems but will fix some that dont have it.



-------------------------

Gigabyte MA790FXT-UD5P
AMD Phnome 2x4 955 Black 3.6GHz (O.C)
G.Skill 16Gig (4x4Gig)DDR3 1333 Dual ch.F3-10666CL7Q RIPJAWS-X
Asus 7770 2GIG 128Bit DDR5
CORSAIR 850tx 850Watt Power Supply
Cooler Master HAF932 ATX Case
Cooler Master V8 CPU cooler
Samsung DVD Burner Sata W/DL/lightscribe
Pioneer DVD burner USB W/DL/Lightscribe
2-WD 250 Gig HD
1-Hitachi 1 TETRABYTE HD
Windows 7 Home Premium 64Bit

 05/23/2013 03:56 PM
User is offline View Users Profile Print this message

Author Icon
MrDimn
Peon

Posts: 7
Joined: 05/17/2013

Thank you for the idea... I did get the latest updates...

Unfortunately, it is still a problem.

 

I am definitely open to any other suggestions.... 

Or perhaps a new Catalyst driver would help! ;-)

 

 

Thanks!


Doug

 05/25/2013 11:57 AM
User is offline View Users Profile Print this message

Author Icon
Destroyer
Peon

Posts: 2
Joined: 05/16/2013

JMcQuade thanks i did what you said and it helped me. Splinter Sell Conviction has better framerate now but still in game  fps drops to 20. I think that this pc sould play it smooth.

 10/26/2013 07:58 AM
User is offline View Users Profile Print this message

Author Icon
WinterWonderland
Peon

Posts: 1
Joined: 10/26/2013

Hi, guys, i have the similar problem: there was update from 12.8 to 13.1 and then i had noticed a low droop in productivity in daily usage, such as browsing,calculating, music, etc., but wnen it came to work with video or with 3D, and games i got the worst FPS ever:10 frames per second was the limit for my PC.

Graphics Card
-ATI Radeon HD 3850 512MB GDDR3


AMD Catalyst Driver Version, and Driver History
- 13.1,8.97.100.7-121116a-160538C-ATI   

Operating System
- 32 bit, Windows XP Professional

Motherboard or System Make & Model
- Asus M2N32-SLI Deluxe  (2 PCI, 1 PCI-E x1, 1 PCI-E x4, 2 PCI-E x16, 4 DDR2 DIMM, Audio, Dual Gigabit LAN, IEEE-1394)

Display Device(s) and Connection(s) Used
- Acer X223H
- DVI to VGA

Applications and Games

- Every game or application connected with the work with video/3D(Pinaccle studio,for example, or 3ds Max)

CPU Details
- AMD Athlon(tm) 64 X2 Dual Core Processor 6000+, MMX, 3DNow (2 CPU's)

Motherboard BIOS Version
-  Award BIOS    Phoenix - AwardBIOS v6.00PG

System Memory Type & Amount
- 2048 Mb  (DDR2-800 DDR2 SDRAM)

Additional Hardware
- 1 ST350032 0AS SCSI Disk Device  (500 Gb, 7200 RPM, SATA-II)

- 1 ST315003 41AS SCSI Disk Device  (1500 ??, 7200 RPM, SATA-II)

Additional Details
- System has cleansed from viruses.

 



Edited: 10/26/2013 at 12:25 PM by WinterWonderland
Statistics
84708 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.