Topic Title: poor GPU performance after driver updates
Topic Summary:
Created On: 06/13/2013 11:32 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 06/13/2013 11:32 AM
User is offline View Users Profile Print this message

Author Icon

Posts: 4
Joined: 06/12/2013

hey, after I updated my XFX radeon HD 6870 1gb dual fan card with new drivers, I've got a really poor framerate in games (team fortress 2 and company of heroes 2 beta are the games I've tested in). I used to run a stable 250 fps in tf2, now it's running around 50 fps with the exact same settings, and in coh2 I get around 5 fps in average, with settings set to "auto detect best".

Now I've tried the 12.6 and 12.8 drivers, as well as 13.4 and 13.6 beta drivers. full uninstall with driver sweeper/driver fusion in between. surely done over 10 installs now. using gpu-z, I can see that the GPU is working at max when the games are running. the temperature is between 30-40 celsius.

 What could be causing this performance loss? I'm running vista 64bit with the latest updates and service packs, I don't think any more info about the pc should be needed since everything worked great before the update? so it gotta be something with the drivers

 06/13/2013 12:03 PM
User is offline View Users Profile Print this message

Author Icon
Heavy Wizardry

Posts: 8744
Joined: 11/13/2009

Please read the sticky "Read Before Posting".

We need to know:

1. Processor (I5-xxxx, A10-xxxx, etc)
2. Graphics card (HD6970, HD4850, etc)
3. OS (Win7, Win8, WinXP, 32 or 64bit, etc)
4. Driver version (13.2, 12.10, etc)
5. Power Supply..list make, model and wattage
6. RAM
7. Did your computer come with the OS and Graphics card you have now?
8. Monitor resolution (native) and connection (DVI, HDMI, VGA, etc)

If this issue is with a LAPTOP please post in the correct forum and list your laptop model...that would be the laptop forum



Intel I7 960 @ 3.87ghz *Intel DX58SO *AMD R9 290 4gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit 

***** cetera fallunt, ludere mortuus ******

 06/13/2013 12:33 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 4
Joined: 06/12/2013

now I've had this computer setup for over a year and it has worked flawlessly up to now, I haven't changed anything apart from the drivers.

as of now I run the 12.6 version of catalyst.

before I updated and got the issue I'm pretty sure I was using either 12.6 or 12.8 too (yes it worked fine back then)

I use 1920x1080 res with HDMI cable

processor is an AMD phenom II x4 940 black edition

Corsair Powersupply 750W Black, ATX Bulk

Corsair TWIN2X PC6400 DDR2 4GB KIT CL5


"AMIBIOS(C) 2009 American Megatrends, Inc.

ASUS M4A79 Deluxe ACPI BIOS Revision 1202"

Edited: 06/13/2013 at 12:41 PM by criZp
 06/13/2013 03:06 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 06/13/2013


I think it is inrelevant to name all those things.

(CPU: i7 920


Memory: 12GB where 8GB from the total is non-paged pool..

Current driver version is 08.00.0915 and the latest beta

I bought it myself

HDMI and VGA, 2 screens next to each other..)

I have windows 8 and I am running Battlefield 3.

On a certain moment the memory leak which was fixed in beta 12.11 is back now. (The non-paged pool memory)...

Let's hope AMD fixes it again

93050 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.