Topic Title: 2nd GPU using seperate driver setup?
Topic Summary: 2+ GPUs independent drivers-profiles
Created On: 06/16/2013 12:07 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 06/16/2013 12:07 AM
User is offline View Users Profile Print this message

Author Icon
speedyg869
Peon

Posts: 2
Joined: 06/15/2013

GiG w/E8400; WXPSP3; 4GB;
Objective: Run OpenCL apps on AMD HD 5570. I'm not trying to setup Crossfire, I just want to put the 5570 to work.
History: After several rounds of uninstall/reinstall/fail, I'm looking for quidance.

I have an HD 4850 GPU in the 1st PCI-Express slot [x16].
Cleaned ATI/AMD with Driver Sweeper and CC.
Installed 13-1-legacy_xp32_dd_ccc_whql.
I added an HD 5570 GPU in the 2nd PCI-Express slot [x8].
Booted. CCC lists the 2nd GPU, but says no driver is loaded.

1Q: Can the legacy card coexist with the 5xxx series?
2Q: If I upgrade CCC, will it balk at legacy device compatibility?
3Q: Will the HD 5570 require the latest CCC, if I install the display driver manually?
4Q: Should I install the HD 5570 1st with the lastest CCC, Then install the HD 4850 dd manually?

Thanks in advance.

 06/16/2013 05:27 AM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

You cannot have both legacy and non-legacy drivers installed as they have file name conflicts (and probably more). You can use a certain version (maybe 12.4, check the release notes for all until you find it) which support both cards. You won't be able to upgrade ever though.

#1: Yes, using that certain driver version.

#2: Yes, it would not only break it, but you'd get a system that BSODs on bootup.

#3: That certain version should work for both. Upgrading that is not an option however.

#4: Nope, that's the same as #2.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 06/16/2013 10:25 AM
User is offline View Users Profile Print this message

Author Icon
Irre84
Peon

Posts: 7
Joined: 05/14/2013

Having problem when I installed my old 4850 gpu whit my 6970. I made it work after hours of diffrent installations.


Belive I had installed 12.6 drivers for the 4850 then installed the 13.4 on the 6970 then 13.1 on the 4850.

When I try that now, it does not work. I have issues whit aloot of stuff. Explorer crashes, CCC crashes and silverlight, youtube streams not working

 06/17/2013 09:55 PM
User is offline View Users Profile Print this message

Author Icon
speedyg869
Peon

Posts: 2
Joined: 06/15/2013

Eydee, Thanks for your help. I got the drivers installed for each card.

In order to get OpenCL support for the HD5570, I installed the AMD APP SDK v2.8 AMD Catalyst™ 12.10 (9.002). According to AMD's directions, I'm supposed to use the AMD Catalyst™ 12.10 (9.002) CCC along with this SDK. Unfortuanately, I cannot locate this CCC package to download. Not in the downloads or the Archive area? So whoever wrote the System Requirements & Driver Compatibility page doesn't realyse that there is not such package.

Here's a link to the page in question.

Hopefully, I'm just overlooking something simple.

Thanks

 06/17/2013 10:38 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7443
Joined: 11/13/2009

List of AMD catalyst and drivers > http://www.techpowerup.com/downloads/Drivers/ATI_Catalyst/



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 


 


 *  Quando Omni Flunkus, Moritati *

Statistics
87527 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.