Topic Title: Can't find drivers for A8-6600k.
Topic Summary: Monitor goes black randomly.
Created On: 06/17/2013 09:31 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 06/17/2013 09:31 AM
User is offline View Users Profile Print this message

Author Icon
Fabrizio89
Peon

Posts: 6
Joined: 03/15/2013

Asrock FM2A75M-DGS Bios updated to 2.5
A8-6600K
4GB 1600Mhz XMS3
XFX Pro 550W

I tried to install the ones from amd site (A series for Windows 7 32bit), and indeed in the release notes http://support.amd.com/us/kbarticles/Pages/AMDCatalyst13-4WINReleaseNotes.aspx there's not the gpu of my apu (8570D), and in fact my monitor goes black randomly every 2 or 3 seconds. If I use the driver downloader, it says it can't find my product. I uninstalled everything AMD related, even using the specific uninstaller from AMD site.

I tried to install the beta drivers, but the screen becomes completely messy. Could it be that the integrated GPU is faulty? If no drivers are installed, it works just fine, but it obviously can't run 3d games.
DxDiag recognizes the cpu and the integrated gpu.

What should I do?



Edited: 06/17/2013 at 09:41 AM by Fabrizio89
 06/17/2013 11:59 AM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

What version of netframework version (4.5), CCC will not work without it. The beta drivers should support the newer APU.



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

 06/17/2013 01:39 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4860
Joined: 12/27/2008

Have you tried other operating systems?



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

Statistics
84656 users are registered to the AMD Support and Game forum.
There are currently 5 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.