Topic Title: Outdated drivers
Topic Summary:
Created On: 06/22/2013 08:44 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 06/22/2013 06:08 AM
User is offline View Users Profile Print this message

Author Icon
Bulldog64
Peon

Posts: 5
Joined: 06/22/2013

Make sure you have your browser setup correctly to download files correctly. I use Firefox and tell it I always want to select where to put the files. More than one question comes to mind when you say your GPU is over heating. Are you using fans in your case that have a high enough rate of air flow to cool your GPU and other components. When you say you recently lost a HD, could it have failed due to over heating. How much cooling one uses in your system has a lot to due with componen'ts life times. If you are using a mid-tower case and cram it full of heat producing components make sure you have enough airflow through the case to cool off your system components or you will continue to have failures no matter what drivers you are using!

I have an extra large case because I liquid cool my CPU and I have several large high airflow output fans through out the case to keep eveything reasonably cool. I have been runnining 2 different RAID systems one of which uses 10,000 RPM Veloci Raptor drives and haven't had a failure for 5 years. I use 2 120mm fans internal in the case to suck the air blowing into the case over the disk drives from a NXT 200mm front case fan. I like to think the extra cooling is one reason I have not had a disk failure yet on drives that produce more heat than the usual 7200RPM drive.



-------------------------
Phenom II 965 BE,ASUS Crosshair V Formula, 2X4GB G.Skill PC3-17000, EFX 6850 HD BE, 2XVelociRaptor 300GB RAID 0, 2x1TB Segate 7200RPM RAID 0, Pioneer Blu-Ray, Cool Master 840 case+ NXT 3X 200mm Fans, WC: 2XSwifttech 50 PSI pumps in Series to CPU
 06/22/2013 06:11 AM
User is offline View Users Profile Print this message

Author Icon
zipsi
Case Modder

Posts: 978
Joined: 11/22/2010

http://www2.ati.com/drivers/13-4_win7_win8_64_dd_ccc_whql.exe for 13.4

http://www2.ati.com/drivers/beta/AMD_Catalyst_13.6_Beta2.exe for 13.6 beta, pick one which you find more useful. Also make sure you have Microsoft .NET Framework 4.0 (or newer) installed, it is a prerequisite for newer Catalyst versions and wouldn't work without it. As for HDD's, keep their temps under 40C and they will last more than half a decade(if they are reasonably used every day).



-------------------------
Intel I7 3770K @ 4.5ghz, Cooler Master Hyper 212 Evo, Gigabyte Z77X-UD3H, Gigabyte HD7970 ghz edition, 4x4gb Kingston HyperX Beast 2133mhz, Seasonic Platinum 860, Samsung 840 Pro 256gb, OCZ Vertex 4 128gb, WD Black 1TB, WD Green 3TB+1.5TB, ASUS Xonar Essence ST, ASUS VE278Q, Windows 3.11
 06/22/2013 08:44 AM
User is offline View Users Profile Print this message

Author Icon
LtmStudMuffin
Peon

Posts: 1
Joined: 06/22/2013

Hey guys. I recently had to buy a new Hard drive because my last one crapped out and I had to redownload a lot of things, one them including drivers. I have the hardest time trying to figure out how to download the lastest drivers so my GPU doesn't over heat just from playing WoW.

Anyway, I digress. So, basically I still have the CD to download the drivers, but they're old drivers and they basically don't work when I try to get onto a game. Also, when I try to download the new driver this error pops up after I reboot

"No ATI Graphics driver is installed, or the ATI driver is not functioning properly. Please install the ATI driver appropriate for your ATI hardware."

I have an addon on my computer called GPU-Z that says I have an ATI RADEON HD 5770 in my computer, so I don't really understand why downloading the drivers isn't working. Can someone please help me?

 

My rig is

Windows 7 64 bit

GFX: ATI RADEON HD 5770

PROCESSOR: Intel 2600k Quad Core i7

mobo is P8H77 VLE

Power Supply: 550w Fatality



Edited: 06/22/2013 at 09:12 AM by LtmStudMuffin
Statistics
84124 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.