Topic Title: Can't update video drivers on Windows 8
Topic Summary:
Created On: 06/23/2013 05:32 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 06/23/2013 05:32 AM
User is offline View Users Profile Print this message

Author Icon
Hellssephiroth
Peon

Posts: 1
Joined: 06/23/2013

1. Fx-8150 4.9ghz
2. Asus Ares II
3. Win 8 64 bit
4. Any recent
5. Antec HCP1200 1200w
6. 16gb gskill 2133mhz
7. Custom
8. HDMI 1920x1080

Basically I cannot install any version of catalyst or drivers it keeps saying installation failed. I have tried about every one known to man that recent. I have tried installing just bits and pieces, cleaning up all the files, down to registry editing and I cannot get one to take hold. I threw in my old 5970 and my old 5870 to see if it was just issues with the card and i cannot get those cards to update either now Its happening on both of my pc's.

Anyone have any ideas? It does work on a fresh install though..... I really dont feel like reinstalling all my stuff if I dont have to though......again. The install is only 1 month old.



Edited: 06/23/2013 at 05:56 AM by Hellssephiroth
 06/23/2013 06:32 AM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4847
Joined: 12/27/2008

Actually the guides you can read on the internet (this site included) give a very bad advice. Never use driver cleaners, uninstall utilities and stuff like that unless you have an already broken system and that's your last chance. Thing is, these applications kill your system, that's why you can't update after using them.

Start out from a clean OS install, and next time you want to update the drivers, just install the new release on top of the old one. You system won't have trouble anymore.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 06/23/2013 03:10 PM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

Use the refresh option of Windows 8 and try again.



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

Statistics
84303 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.