Topic Title: Need help installing Radeon HD 7570
Topic Summary: Radeon HD 7570 drivers not working
Created On: 07/03/2013 12:19 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/03/2013 12:19 PM
User is offline View Users Profile Print this message

Author Icon
sindyr
Peon

Posts: 2
Joined: 07/03/2013

Here is the requested info:

Graphics Card
-stock Radeon HD 7570

AMD Catalyst Driver Version, and Driver History
- attempted install of 2 varieties: latest AMD and beta AMD

Operating System
- Wndows 7 64 bit, both with and without SP1

Issue Details
When I try to run the downloaded drivers, i get the same behaviour:

1) The installation does not actually fail.

2) It does come up with a message partway through the process:

Current Version Not Installed
AMD CIM Installation Package

3) While the process does complete, when it comes up with the list of things it is about to install, a driver is not on that list. Sure enough, after the install is finished, device manager shows the same Standard VGA Graphics, NOT the actual HD 7570.

This is a fresh install on windows 7 - fresh as in hours ago.

How can I get the proper driver for the Radeon HD 7570 installed? Windows 7 is driving a little nuts with it's aero transparency off!

Motherboard or System Make & Model
- Asus P5B Deluxe

Power Supply

- No Name brand, 460 watts.

Display Device(s) and Connection(s) Used
- Basic 1280 x 1024 monitor conected via DVI

Applications and Games

-just windows

CPU Details
- no overclocking, Intel Core 2 Quad Extreme 2.66GHz

Motherboard BIOS Version
- AMIBIOS 1004 ( think?)

System Memory Type & Amount
- 4 GB, Corsair

Additional Hardware
- nothing else special

Additional Details
- tested video card in another windows 8 system, it worked fine, proper drivers installed. It's only in this win7 64 system I am have trouble.

 07/05/2013 08:27 AM
User is offline View Users Profile Print this message

Author Icon
sindyr
Peon

Posts: 2
Joined: 07/03/2013

Still need help...

 07/05/2013 10:25 AM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

Is the hardware id of your card in the inf file?



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 07/05/2013 11:37 AM
User is online View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12898
Joined: 04/17/2008

Catalyst 13.6 Beta HD 7000 series support:

AMD Product Compatibility:

AMD Radeontm HD 7900 Series
AMD Radeon HD 7800 Series
AMD Radeon HD 7700 Series


Catalyst 13.4 HD 7000 series support:

AMD Desktop Product Family Compatibility

AMD Radeontm HD 7900 Series (incl. HD7990)
AMD Radeon HD 7800 Series
AMD Radeon HD 7700 Series (incl. HD7790)
AMD Radeon HD 7660D Series
AMD Radeon HD 7560D Series
AMD Radeon HD 7300 Series


Means use the driver provided by whoever made your card, or the PC if it is a prefab (HP, Compaq, etc)

-------------------------
AMD FX-8350 w/ Corsair H105, ASUS Sabertooth 990FX Gen3/R2, 8GiB G.SKILL DDR3-2133, XFX HD 7970, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, Corsair C70, HP ZR2440w, Win 7 Ultimate x64
Statistics
87556 users are registered to the AMD Support and Game forum.
There are currently 9 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.