Topic Title: Radeon HD 4600 Series not detected
Topic Summary: My graphics card isn't detected after reformat and Catalyst Suite install
Created On: 07/15/2013 03:07 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/15/2013 03:07 PM
User is offline View Users Profile Print this message

Author Icon

Posts: 1
Joined: 07/15/2013

Windows XP Professional, Service Pack 3

MSi MS-7222 aka (PM8PM-V)

Intel(R) Pentium(R) D CPU 2.66GHz (2CPUs) 2gb RAM

ATI Radeon HD 4600 Series AGP

Sound Blaster Audigy 2 Audio

I just inherited this PC from my brother. I needed to reformat, however he didn't have his original Windows XP Pro install disc. So I had to use an old version XP Pro Service Pack 1. I reformatted, updated to SP3 and ran the IE Windows Updater. Then I started to update the drivers. My brother didn't have the disc's for these either so I have been getting them off the Manufacturer websites. First I tried to update the MB drivers. The Realtek and 4in1 chipset drivers installed fine. But, once I got to the VIA/S3G UniChrome Display Driver I got an error saying "S3GSetup No compatible hardware was detected. (Err -21)".  I tried going into the Device Manager to manually install it. There is no Display Adapters tab. There is however a "Video Controller (VGA Compatible)" device with a Yellow question mark and exclamation point under the "Other devices" tab. I tried to update the driver from the specific location of the S3G motherboard driver. The Wizard couldn't find the necessary software however. I tried a few other fixes I can't recall of the top of my head but nothing worked.

So I decided maybe I could skip over it and tried to install my graphics card driver. After installing Catalyst Software Suite my graphics card was not detected in DirectX. The driver menu is not in the bottom right hand corner. Uncertain if this "Video Controller" needed my onboard driver or my graphics card driver. I tried to manually update the "Video Controller" driver from the specific location of the Catalyst Software Suite. But it couldn't find the necessary software either. I tried 3 different versions of the Catalyst Suite, 12.6, 13.1, and 13.4. All produced the same result. I read that sometimes you have to disable the onboard graphics in BIOS. Even though I've read most MSi MB's disable it automatically I was desperate for a solution. So I went into BIOS found a VGA Share Memory option and set it from 64mb to Disabled, but that also had no effect. So I set it back to 64mb. Most other fixes are telling me to download Driver programs but I'm a little wary about that as the ones I've tried I'd have to pay for. I guess I will fork out the money if I have to. But I would much rather figure this out for free. Any help would be appreciated. Thanks for your time and sorry for long post I just wanted to give a much information as possible.

 07/15/2013 04:02 PM
User is offline View Users Profile Print this message

Author Icon
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

You need this one.


CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 07/15/2013 04:04 PM
User is offline View Users Profile Print this message

Author Icon
Forum Moderator

Posts: 774
Joined: 07/30/2012

I assume you want to use the HD4600 AGP card, instead of the motherboard onboard graphics - VIA/S3G UniChrome?

Can you confirm you have the monitor connected to the HD4600, or the onboard?  You should have the monitor connected to the HD4600 (if that is what you want to use) and then just verify that the motherboard's BIOS is setup correctly. In the BIOS, look for settings to ensure the onboard graphics is disabled and/or the primary graphics adapter is set to the AGP card.

Inspect the video card, and see if you can determine who the partner manufacturer was for it.  Sapphire, Visiontek, HIS, etc..  Try to use their specific driver (from their website) for the video card.



AMD Customer Care

The information presented in this document is for informational purposes only and may contain technical inaccuracies, omissions and typographical errors. Links to third party sites are for convenience only, and no endorsement is implied.

92918 users are registered to the AMD Support and Game forum.
There are currently 1 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2015 FuseTalk Inc. All rights reserved.