Topic Title: Windows 8 and BSOD while installing AMD HDMI audio driver (AtihdW86.sys)
Topic Summary:
Created On: 07/16/2013 07:23 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 07/16/2013 07:23 AM
User is offline View Users Profile Print this message

Author Icon
kokos
Peon

Posts: 4
Joined: 07/16/2013

Hello!

I receive BSOD while trying to install display drivers for my graphics card and I don't know how to resolve it. It's related to AtihdW86.sys (SYSTEM_THREAD_EXCEPTION_NOT_HANDLED). Below information about the system and the BSOD. I'd appriciate any input. Thank you very much.

Graphics card: HIS ATI Radeon HD6870 1024MB DDR5/256bit DVI/HDMI/DP PCI-E (900/4200)

Catalyst installer: 13-4_win7_win8_64_dd_ccc_whql

Operating System: Windows 8 Pro, 64-bit

Mainboard: Gigabyte GA-880GMA-UD2H A880G SAM3 (GA-880GMA-UD2H)

 

What I do:

1. Remove all AMD related drivers using: amd_cleanup_util_1.2.1.0

2. Restart system

3. Uninstall AMD devices using hardware management Windows console

4. Refresh the devices [they install with drivers delivered with Win8 - AMD Radeon HD 6800 Series (Microsoft corporation - WDDM v1.20 - AMD inc, ver 8.97.10.6)]

5. Start installation of 13-4_win7_win8_64_dd_ccc_whql

When installer is performing installation step for AMD HDMI audio driver suddenly Windows crashes.

 

BSOD info:

 

 07/16/2013 08:43 AM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4883
Joined: 12/27/2008

If you don't use HDMI audio, skip installing this component. If you do, also skip it, and try the drivers from the Realtek website instead.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 07/16/2013 08:50 AM
User is offline View Users Profile Print this message

Author Icon
kokos
Peon

Posts: 4
Joined: 07/16/2013

Thanks Eydee, I'll try that. I'd prefer to keep whole functionality. Do you know what can be a cause of this problem? Is it something common? Thx again. 

 07/16/2013 09:17 AM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4883
Joined: 12/27/2008

It looks like an issue with the driver itself. There was an HDMI audio fix in 13.6 beta2. Maybe related to your issue, maybe not. Check it out if you have no problems with using beta drivers. You can also try the Realtek drivers, as I suggested above.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 07/16/2013 02:52 PM
User is offline View Users Profile Print this message

Author Icon
kokos
Peon

Posts: 4
Joined: 07/16/2013

Thanks a lot.

OK, I'd prefer to stay with stable for now. I was trying beta earlier, and I had bad experience (also changes related to the HDMI drivers were listed in change log).

So.. I installed all the drivers without the HDMI audio option. It went well, but after the restart it occurred that the AMD driver is not in use for my graphics card. I needed to update it manually via hardware management console, pointing the C8157485.inf. After this, I think, right driver is in use.

Realtek drivers don't work for me..

Do you think I should report my problem somewhere more official way or it's rather pointless?

Thanks again.

Kind regards,

Konrad

 08/04/2013 02:21 AM
User is offline View Users Profile Print this message

Author Icon
kokos
Peon

Posts: 4
Joined: 07/16/2013

Well.. I'm also not satisfied with AMD support for my device, I'm not so angry, but - you're right - next time I'll choose an alternative, most probably I'll be back to NVIDIA.

Statistics
84980 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.