Topic Title: 13.8 beta drivers
Topic Summary: uninstall
Created On: 08/12/2013 10:40 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 08/12/2013 10:40 PM
User is offline View Users Profile Print this message

Author Icon
blizzard105
Peon

Posts: 2
Joined: 08/12/2013

Hello all,I want to go back to the previous drivers I had installed before installing 13.8 beta.  However, when I try to uninstall them I get a BSOD. I have tried going back by uninstalling and rolling back the drivers in device manager but nothing works.  I have even tried to delete things manually but to no avail. I also tried to install and earlier version (13.1) but that didn't work either.

-------------------------
 08/12/2013 10:43 PM
User is offline View Users Profile Print this message

Author Icon
blizzard105
Peon

Posts: 2
Joined: 08/12/2013

By the way I have a 5770 video card.

-------------------------
 08/14/2013 04:42 AM
User is offline View Users Profile Print this message

Author Icon
mark.stewart@shaw.ca
Peon

Posts: 9
Joined: 08/14/2013

That's unfortunate, about Catalyst beta resulting HD5570 BSOD. ... I do system checks with Microsoft dev frequently, so you may regard this advice as expert. We have determined that Catalyst install makes permanent changes to the Windws 8 OS. That is, changes which permanently optimize OS for card being installed by Catalyst Manager. If you remove AMD Catalyst, you should expect to immediately reinstall your OS. ... Concerning suitability of AMD driver install and/or removal, Windows 8 has initiated a new appraoch to driver manufacturer management. Microsoft will no longer machine-fit device inf. Windows users and device manufacturers must now provide their own inf profiles for all Windows hardware. In other words, Windows graphics per OS install are one-shoe-fits-all from now on. Sound cards went through Windows 8 driver rush early 2013. Video cards now subjected to system non-support faced by audio earlier this year. ... You may find you can live with Microsoft's on-shoe solution. Personally, it is problem free, as any problem is immediately approached by Microsoft support and resolved. However, one-shoe may not fit your requirements. I have two displays in a Crossfire configuration. AMD Crossfire worked fine for years. Until Microsoft adopted its money-saving one-shoe fit. My only complaint now concerns pixel-mapping. Pixel map for user selected "primary" display is snapped onto second display. Unless each Crossfire display has an identical dimansion and display dimensioning capability, icons and desktops are going to cause problems that never appear with the drivers from AMD. Unfortunately, AMD drivers are causing Device Manager conflicts that result system wide collapse. ... You see, AMD has always commited detailed and sophisticated device profiles to fit in with Microsofts pre-Windows 8 display subsystem. Now that Microsoft has cut back on its investment in user ease of use, device manufacturers must as quickly as possible fill in the gaps Microsoft has opened for all non-Microsoft devices. Not blaming Microsofot or Device people, but economy must adapt. ... How you adapt to Microsoft's new, cheaper device regime is up to you and your affordable system support resources. Remember, Microsoft is a good resource unless say Crossfire has pixel-map critical issues. I am waiting for an AMD solution for my AMD HD6970 Crossfire, where displays icons cannot be placed in bottom icon row of other displays. ... Microsoft and AMD have both on telephone advised using upcoming, driver assembly from AMD. AMD cannot afford fit for existing/old drivers. If Beta fails, report using form at bottom of any driver Download page. ... It's a nuisance to have all my icons in just one display, when i prefer keeping projects and icons on at least 2 or 3 separate displays. Hope all of this information inspires good solution for all.
 08/14/2013 05:41 AM
User is offline View Users Profile Print this message

Author Icon
mark.stewart@shaw.ca
Peon

Posts: 9
Joined: 08/14/2013

On my new mainly Intel hardware, current 13.4 and all older AMD Catalyst Managers going back two years will cause Device Manager conflicts, resulting what Microsoft calls "system instability". In other words, as soon as any AMD Catalyst is installed on Windows 8 with AND Crossfire, system will corrupt and OS must be immediately reinstalled. AMD as per previous post is greatly impacted by new Microsoft driver policy. If AMD cannot look after it's customers, we all have to make do with an almost reliable Microsoft one-shoe solution. Device standardization is also a War On Terror objective in all American colonies, so economic and political failings impact the global Imperial government network now failing our display subsystems. My somewhat aged personal advice: be patient. They'll all calm down so they can sort out their problems. We should move forward based on their professional support advice. My support advice from Microsoft and AMD is for an $800 AMD video card sub-system.
 08/14/2013 04:20 PM
User is offline View Users Profile Print this message

Author Icon
osv1
Peon

Posts: 7
Joined: 08/14/2013

mark.stewart wrote: "amd crossfire has worked fine for years"... that is a grossly incorrect statement, mark, amd crossfire has been broken since it's inception, the issues with runt frames and such have been well documented within the last few months.
 08/14/2013 04:28 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7250
Joined: 11/13/2009

Originally posted by: blizzard105 Hello all,I want to go back to the previous drivers I had installed before installing 13.8 beta.  However, when I try to uninstall them I get a BSOD. I have tried going back by uninstalling and rolling back the drivers in device manager but nothing works.  I have even tried to delete things manually but to no avail. I also tried to install and earlier version (13.1) but that didn't work either.

There is a post in the "help&FAQ" section which gives some guidance.

How to install and uninstall drivers

If that doesn't work, then furnish the info thats asked for in PLEASE READ BEFORE POSTING and maybe someone can help.



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

 08/15/2013 10:05 PM
User is offline View Users Profile Print this message

Author Icon
Earnhardt
Case Modder

Posts: 882
Joined: 09/11/2008

I have used crossfire on every series since the 3870's with no issues whatsoever.

-------------------------

AMD Phenom II 1100t @4.0Ghz /Asus sabertooth 990fx/2x Gigabyte 3G 7950's in crossfire/500G samsung 840 ssd/16G G-Skill Ripjaw 1600/2-samsung 24" monitors 1920X1200/Corsair AX1200W psu/W7 pro 64,G19 keyboard,Roccat kone pure mouse,Cooler master HAF932,Corsair H100i water cooler,Zalman ram cooler.Sound Blaster X-Fi Titanium Fatal1ty Champion Series,Logitech Z5500 speakers,Roccat Kave 5.1 headset.

 08/15/2013 10:53 PM
User is offline View Users Profile Print this message

Author Icon
UcouldBrong
Case Modder

Posts: 801
Joined: 01/05/2013

Sometimes it takes more than one install to get it working properly.

 

Hopefully, someone has actually read those tomes above and can translate to the rest of us.



-------------------------

 


 


Non-noob components.

 08/17/2013 08:51 AM
User is offline View Users Profile Print this message

Author Icon
Wagnard
Peon

Posts: 8
Joined: 11/09/2008

Originally posted by: blizzard105 Hello all,I want to go back to the previous drivers I had installed before installing 13.8 beta.  However, when I try to uninstall them I get a BSOD. I have tried going back by uninstalling and rolling back the drivers in device manager but nothing works.  I have even tried to delete things manually but to no avail. I also tried to install and earlier version (13.1) but that didn't work either.

 

You should try my DDU in safe mode. It will take care of your problems.

If it work, I would apreciate feedback on the guru3d thread 

Here is the thread : http://forums.guru3d.com/showthread.php?t=379505

Statistics
85455 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.