Topic Title: Monitor not detected
Topic Summary:
Created On: 09/05/2013 07:59 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 09/05/2013 07:59 PM
User is offline View Users Profile Print this message

Author Icon
Arundor
Peon

Posts: 1
Joined: 09/05/2013

I use 3 monitors on my system.  The setup has worked fine for years so I know there is no hardware incompatibility.  Between yesterday and today something has happened that causes my 3rd monitor to not be detected.  I have clicked the "Detect Displays" button in Catalyst Control Center several times without any effect.  No software or hardware was changed between yesterday and today so I'm not sure why the 3rd monitor is suddenly not being detected.

 

I haved tried using the problematic monitor on a different computer and it did work, so I know the monitor isn't dead.

 

I am running Windows 7 with Catalyst version 13.4.  My 3 monitors are a Dell U2410 and two Samsung 932BF.  The Dell is connected using Displayport and the two Samsungs are connected using DVI.  It is one of the two Samsungs that is not being detected.  I have two video cards, an HD 6850 and HD 6870 in CrossfireX.

 

I've tried the following fixes:

 

- Used the "Detect" button in the Control Panel display settings and the Catalyst Control Center.

- Scanned for new hardware in Device Manager.

- Confirmed that the monitor was set to use the correct input (in this case DVI).

- Tried turning off CrossfireX.

- Unplugged all other monitors and left the problematic monitor as the only monitor connected.

- Tried swapping the DVI ports of the working and non-working monitors.

- Tried different cables.

- Tried different cable types, I was originally using DVI but I also tried VGA to see if it would work.

- Cleaned the contacts on the cables and the input ports on the monitor.

- Fully uninstalled then reinstalled my display drivers (AMD Catalyst 13.4 is what I had been using both before and after)

- Reseated my graphics card and the power cable to the graphics card.

 

Now I'm out of ideas on how to get this working. Any suggestions?

Statistics
88761 users are registered to the AMD Support and Game forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.