Topic Title: "Display driver stopped responding and has recovered"
Topic Summary: Tried a lot of fixes, don't know what else to do.
Created On: 09/12/2013 04:27 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 09/12/2013 04:27 AM
User is offline View Users Profile Print this message

Author Icon
SocialRhubarb
Peon

Posts: 1
Joined: 09/12/2013

I get the "Display driver stopped responding and has recovered" error message whenever I start up, and when I try to run any games, even minesweeper. The screen will freeze up, then flash to black, and then come back again, still frozen, and repeat until I am able to close or exit the application. I've tried uninstalling and reinstalling drivers numerous times. The computer is quite new, was working for about a week before the issue appeared. Was running Starcraft II when it first happened. I also can't open Catalyst Control Centre as the aforementioned problem occurs when I do.

Graphics card: Powercolor HD7950 Boost State V5 3GB

OS: 64-bit, Windows 7

Motherboard:


Gigabyte GA-B85M-D3H

i5 4440
RAM: G.Skill Ares F3-1866C9D-8GAB 8GB (2x4GB) DDR3 



Edited: 09/12/2013 at 04:45 AM by SocialRhubarb
 09/12/2013 05:07 AM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

I suggest you first try the card in a nother computer, and if it does the same thing, RMA it.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 09/18/2013 11:42 AM
User is offline View Users Profile Print this message

Author Icon
arthus2222
Peon

Posts: 1
Joined: 09/18/2013

i got the same problem! but what is RMA?

 09/18/2013 12:20 PM
User is offline View Users Profile Print this message

Author Icon
stumped
Wizard

Posts: 7278
Joined: 11/13/2009

....and did this start when you tried to install new drivers from AMD? You should read the post on "TDR" issues in the FAQ section?



-------------------------

Intel I7 960 @ 3.87ghz *Intel DX58SO *HIS HD6970 2gb *Corsair TX650M *2x4gb Corsair XMS3 *WD Black 1TB *Windows 7 Home Premium 64bit ***Asus N71Jq laptop *Intel I7 720QM Processor *Mobility Radeon HD5730 1gb *8gb Ram *Windows 7 64bit ** Toshiba P75-A7200 * Intel I7-4700MQ * Windows 8.1 64bit


 


 * A clear conscience is usually a sign of bad memory *

 09/27/2013 08:47 AM
User is offline View Users Profile Print this message

Author Icon
Zuluknob
Peon

Posts: 21
Joined: 12/30/2012

RMA=Return to Manufacturer

Statistics
86509 users are registered to the AMD Support and Game forum.
There are currently 9 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.