Topic Title: Radeon 5870 Drivers having trouble with OpenGL
Topic Summary:
Created On: 09/13/2013 12:29 AM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 09/13/2013 12:29 AM
User is offline View Users Profile Print this message

Author Icon
HJW012
Peon

Posts: 1
Joined: 09/13/2013

Until recently I have had no real need to update my graphics card drivers. I did however need OpenCL support for an application I was attempting to use and decided to find an AMD driver that supported it. I found the correct driver and installed and a lot happened. First off, my former dual displays just became the same desktop just mirrored. Secondly, the resolution went from over 1080p to under 720p which startled me quite a lot. An error message came up saying that the current driver was having issues so I rolled back to my previous and now the appearance is back to normal. However, when I try to run anything requiring accelerated OpenGL, like Minecraft, I have an error saying to update my drivers. When I do, it changes the resolution and monitors again and I am forced to roll back again. The OpenCL problem is also still not fixed. I am sorry that I am not terribly tech-savvy. Any feedback is helpful and if any further information is needed, please don't hesitate to ask. Thank you!

 09/13/2013 02:52 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

You probably reverted to the drivers which are provided by the OS/Windows update. Those drivers have no OpenGL components.

What driver package were you trying to update to? How did you do it exactly?



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 09/18/2013 10:28 AM
User is offline View Users Profile Print this message

Author Icon
12oad
Peon

Posts: 17
Joined: 09/17/2013

I feel your pain bro, im having almost the same problem. There are: Quake3Arena and QuakeLive , openGL based games. When i run them my gpu is idle, and all the work is done by CPU. 

My conclusion: Some versions of OpenGL - doesn't work with AMD. shame

http://forums.amd.com/game/messageview.cfm?catid=443&threadid=167972&enterthread=y (my problem)

Statistics
85393 users are registered to the AMD Support and Game forum.
There are currently 4 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.