Topic Title: Microsoft FSX crashes hard with 13.9 Driver Suite! Please address this!
Topic Summary:
Created On: 09/22/2013 11:16 AM
Status: Post and Reply
Linear : Threading : Single : Branch
1 2 Next Last unread
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 09/22/2013 11:16 AM
User is offline View Users Profile Print this message

Author Icon
cvearl
Peon

Posts: 21
Joined: 09/22/2013

I own a 7970 on Windows 7 64. FSX ran like a champ and bug free on 13.4. 13.9 is a nightmare!

I spend alot of time helping FSX users that own AMD cards to get the most of the game at the usual forums like AVSIM (dozens and dozens of AMD customers) and up until recently, things were very good. That was until we went from 13.4 to 13.9. Basically running DX9 mode in the game is where the issues are. Now the game crashes to desktop and gets FATAL errors.Any help would be appreciated.

http://forum.avsim.net/topic/421549-catalyst-139-not-working-and-subsequent-catastrophy/

Charles.



-------------------------


Edited: 09/22/2013 at 02:38 PM by cvearl
 09/22/2013 11:24 AM
User is online View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12187
Joined: 04/17/2008

So go back to 13.4?

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
 09/22/2013 12:32 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4844
Joined: 12/27/2008

Originally posted by: black_zion So go back to 13.4?

This. Also I don't even understand what the point is in upgrading to an already outdated driver. Update to 13.10 or don't update.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 09/22/2013 02:36 PM
User is offline View Users Profile Print this message

Author Icon
cvearl
Peon

Posts: 21
Joined: 09/22/2013

Originally posted by: black_zion So go back to 13.4?

As a short term solution yes. We all went back to 13.4

But the new drivers may fix issues in other games I might play. So then what. FSX is a basic DX9 game and this update broke it.

So if it gets left behind in subsequent driver releases I will have to go nVidia sadly. Not something I really want to do. I buy alot of ATI cards for personal use and in training sim builds and dont want to have to change my builds.

Charles.



-------------------------
 09/22/2013 02:45 PM
User is offline View Users Profile Print this message

Author Icon
cvearl
Peon

Posts: 21
Joined: 09/22/2013

Originally posted by: Eydee
Originally posted by: black_zion So go back to 13.4?

 

This. Also I don't even understand what the point is in upgrading to an already outdated driver. Update to 13.10 or don't update.

 

Seriously? 13.9 was released Sept 18th and is the current certified driver. 13.1 is BETA. 

http://support.amd.com/us/gpudownload/windows/Pages/radeonaiw_win8-64.aspx

On that note. Why is 13.1 newer than 13.9 Whats up with this numbering? It went 13.4, 13.9 and now 13.1 ?

C.



-------------------------
 09/22/2013 02:45 PM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

So you went back to 13.4, did you fill out a problem report for any of the other drivers. That is the only way it will be fixed. Telling fellow user here will not get it fixed.



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

 09/22/2013 02:48 PM
User is offline View Users Profile Print this message

Author Icon
cvearl
Peon

Posts: 21
Joined: 09/22/2013

Originally posted by: WMudrockJr So you went back to 13.4, did you fill out a problem report for any of the other drivers. That is the only way it will be fixed. Telling fellow user here will not get it fixed.

 

Yes I did. 

Thought this was the AMD support forums. If it is not, I guess I need to find them still. Is there somewhere AMD techs answer directly? (Catalyst Maker still around these days?) .. Oh wait the name of the forum is AMD support and Games. I guess that's what I thought it was. 

Just be advised then that 13.9 breaks FSX if you are someone that uses it I guess.

Charles.



-------------------------
 09/22/2013 05:02 PM
User is online View Users Profile Print this message

Author Icon
black_zion
80 Column Mind

Posts: 12187
Joined: 04/17/2008

Just because a driver is newer doesn't mean it is better. I wasn't able to use any of the 11.x series of drivers due to issues, I used Catalyst 10.10e until 12.3. If it isn't broke, don't fix it.

-------------------------
ASUS Sabertooth 990FX/Gen3 R2, FX-8350 w/ Corsair H60, 8 GiB G.SKILL RipjawsX DDR3-2133, XFX HD 7970 Ghz, 512GB Vertex 4, 256GB Vector, 240GB Agility 3, Creative X-Fi Titanium w/ Creative Gigaworks S750, SeaSonic X750, HP ZR2440w, Win 7 Ultimate x64
 09/23/2013 01:05 PM
User is offline View Users Profile Print this message

Author Icon
Hardwood
Dungeon Master

Posts: 4001
Joined: 01/27/2008

There are AMD staff here and perhaps they'll relay the problem. Also post on "Rage3d" as there are AMD staff around there too.



-------------------------

#1: Phenom II C2 955BE @ 3.6, Antec Kuhler 920, Gigabyte GA-MA790FX-DS5, Asus 5870/V2, ASUS Xonar D2X, 4 x 1gig OCZ2N1066SR2GK @800, Antec Truepower New 750, Arc Midi, Vistax64
#2: MSI A88X-G45, AMD A10-7850K, IGP, AMD 2x4GB 2133 (R938G2130UK), Antec 750 True, 128GB Sandisk SSD, WD Black 1TB, Win8.1pro x64
#3: Athlon 64 X2 4200+, AGP 1950pro, Audigy 2, Asus A8V-D, 2gig ram, Enermax 465P, Antec900case. Now on Win8.1pro cat 10.2

 09/23/2013 01:39 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4844
Joined: 12/27/2008

Originally posted by: cvearl
Originally posted by: Eydee
Originally posted by: black_zion So go back to 13.4?

 

 

 

This. Also I don't even understand what the point is in upgrading to an already outdated driver. Update to 13.10 or don't update.

 

 

 

 

Seriously? 13.9 was released Sept 18th and is the current certified driver. 13.1 is BETA. 

 

http://support.amd.com/us/gpudownload/windows/Pages/radeonaiw_win8-64.aspx

 

On that note. Why is 13.1 newer than 13.9 Whats up with this numbering? It went 13.4, 13.9 and now 13.1 ?

 

C.

 

Beta means no WHQL here only. Also read the release notes:

FEATURE HIGHLIGHTS OF AMD CATALYST™ 13.9

The AMD Catalyst 13.9 WHQL is AMD’s first logo certified driver for Windows 8.1.  It does not include support for Frame Pacing or the very latest AMD CrossFire™ optimizations.  AMD Catalyst 13.10 Beta includes additional performance improvements and fixes not found in AMD Catalyst 13.9 WHQL.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 09/25/2013 03:04 AM
User is offline View Users Profile Print this message

Author Icon
AMDSam
Peon

Posts: 23
Joined: 03/29/2011

Originally posted by: Eydee
Originally posted by: black_zion So go back to 13.4?

 

This. Also I don't even understand what the point is in upgrading to an already outdated driver. Update to 13.10 or don't update.

 

Why call a beta a beta when it is better than a WHQL release? Why even bother getting them certified if they are randomly junk?

Also black_zion, the attitude of "so just go back to 13.4" is abysmal. I hope you aren't working in support for any product.



-------------------------

i5-760, Asus P7P55 LX, Sapphire HD7950 OC Ed, 16GB RAM, Vertex 3 240GB, WD Black Cav 1TB, Auzentech Prelude, Win7 Ult x64 SP1

 09/25/2013 12:07 PM
User is offline View Users Profile Print this message

Author Icon
Qwixt
Buffed

Posts: 87
Joined: 02/07/2008

Originally posted by: AMDSam
Originally posted by: Eydee
Originally posted by: black_zion So go back to 13.4?

 

This. Also I don't even understand what the point is in upgrading to an already outdated driver. Update to 13.10 or don't update.

 

 

Why call a beta a beta when it is better than a WHQL release? Why even bother getting them certified if they are randomly junk?

 

Also black_zion, the attitude of "so just go back to 13.4" is abysmal. I hope you aren't working in support for any product.

 

What are the other options? 

As far as 13.9 being released after 13.10 and not containing all the samefixes, that is strange at first glance. When developing, you take snapshots of code, and branch at certain milestones. This is what amd did once they reached a driver good enough to support windows 8.1. The approval process takes long enough that it was delayed.

So they cut a branch, 13.9, to support windows 8.1, and after that, I am guessing they made 13.10 to get some changes done for TW Rome II. Since 13.10 does not require the long approval process, 13.10 shows up earlier.

 

 09/25/2013 01:37 PM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

It's 13.10 Beta while 13.9 is the WHQL release in the 9th month so they had to number the beta as 13.10 Beta.



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

 09/29/2013 06:37 PM
User is offline View Users Profile Print this message

Author Icon
cvearl
Peon

Posts: 21
Joined: 09/22/2013

Sadly 13.10 BETA causes the same error. Exiting FSX (DX9 mode) results in FATAL ERROR.

This is FSX Gold Edition with Acceleration Pack known as SP2. Error does not occure with 13.1 and 13.4

Faulting application name: fsx.exe, version: 10.0.61637.0, time stamp: 0x46fadb14

Faulting module name: atiumdag.dll, version: 9.14.10.991, time stamp: 0x522828fd

Exception code: 0xc0000005

Fault offset: 0x00024f01

Faulting process id: 0xbcc

Faulting application start time: 0x01cebccf2db83f06

Faulting application path: C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\fsx.exe

Faulting module path: C:\Windows\system32\atiumdag.dll

Report Id: a073c7b2-28c2-11e3-816c-bcaec5cea514



-------------------------
 10/09/2013 09:11 PM
User is offline View Users Profile Print this message

Author Icon
cvearl
Peon

Posts: 21
Joined: 09/22/2013

FATAL ERROR with 13.11 as well in FSX.

Faulting - >  atiumdag.dll again.

C.

 



-------------------------
 10/17/2013 09:41 PM
User is offline View Users Profile Print this message

Author Icon
udidwht
Buffed

Posts: 92
Joined: 03/07/2009

Originally posted by: cvearl
Originally posted by: black_zion So go back to 13.4?

 

As a short term solution yes. We all went back to 13.4

 

But the new drivers may fix issues in other games I might play. So then what. FSX is a basic DX9 game and this update broke it.

 

So if it gets left behind in subsequent driver releases I will have to go nVidia sadly. Not something I really want to do. I buy alot of ATI cards for personal use and in training sim builds and dont want to have to change my builds.

 

Charles.

 

 

Same issue her. Rolled back to 13.4

@cvearl...Doing so will only trade this issue for an even more pesky one. Google nvdlmkm.sys (NVIDIA related). And an issue that was my reason for dumping them and coming over to ATI chip. It is/was a constant with NVIDIA cards for some time now.



-------------------------

Win7Ult.64BitSP1,Corei5/2500K,Giga-GA-Z68XP-UD3,XFXHD7870DD,8GBDDR3,SndBlstrXfiXGamer,LGBlue Ray Writer,ANTEC650W,x2-1TB SATA3's

 10/18/2013 09:15 PM
User is offline View Users Profile Print this message

Author Icon
cvearl
Peon

Posts: 21
Joined: 09/22/2013

Originally posted by: udidwht
Originally posted by: cvearl
Originally posted by: black_zion So go back to 13.4?

 

As a short term solution yes. We all went back to 13.4

 

But the new drivers may fix issues in other games I might play. So then what. FSX is a basic DX9 game and this update broke it.

 

So if it gets left behind in subsequent driver releases I will have to go nVidia sadly. Not something I really want to do. I buy alot of ATI cards for personal use and in training sim builds and dont want to have to change my builds.

 

Charles.

 

 

Same issue her. Rolled back to 13.4

@cvearl...Doing so will only trade this issue for an even more pesky one. Google nvdlmkm.sys (NVIDIA related). And an issue that was my reason for dumping them and coming over to ATI chip. It is/was a constant with NVIDIA cards for some time now.

 

One work around in FSX which I have not done yet is take the atiumdag.dll from 13.5 and put it in the FSX root folder. FSX will use that instead and then 13.9 10 and 11 all work without crashing.

My question becomes... What is atiumdag.dll for? And will this even matter. I would use that as a work around if I knew it was not important in some way.

Charles.



-------------------------


Edited: 10/26/2013 at 10:17 AM by cvearl
 10/18/2013 10:42 PM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

I believe it is listed as the DirectX Universal driver. 

I have moved atioglxx.dll from 13.1 as temporary fix for Doom 3.



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

 11/11/2013 09:09 AM
User is offline View Users Profile Print this message

Author Icon
milnerajm
Peon

Posts: 2
Joined: 11/11/2013

I have only just updated to 13.9 and now have the same crash problems with FSX. Tried to download 13.4 but AMD site asks for earlier version of Net and when I try to download this it says I have a later version. So I uninstalled 13.9 and reinstalled 13.1 which I saved on my PC. This gave me big problems, Windows would not install, blue screens, and only by luck has Windows managed to repair itself. However now I still have 13.9 on my machine - can anyone help. Does AMD have a support email ?Help 
 11/11/2013 10:00 AM
User is offline View Users Profile Print this message

Author Icon
cvearl
Peon

Posts: 21
Joined: 09/22/2013

Originally posted by: WMudrockJr I believe it is listed as the DirectX Universal driver. 

 

I have moved atioglxx.dll from 13.1 as temporary fix for Doom 3.

 

 

#1. BETA driver 13.11 version 9.2 works now with FSX.

#2. You should have done a complete uninstall. From Control Panel Add Remove Programs in Windows. Should have used Catalyst Install Manager and done a complete Express Uninstall All AMD software. Rebooted and Installed the next driver. Then repeat the routine to go backwards as well.

Proper uninstall before installing the new driver is right herer... http://support.amd.com/en-us/kb-articles/Pages/GPU57RemoveOldGraphicsDrivers.aspx

What I might try if I were you is reinstall 13.9 right over top what you have. and reboot. Then do a full uninstall through Catalyst Install Manager and reboot and then download and install 13.11 BETA Version 9.2

Charles.

 



-------------------------
Statistics
84114 users are registered to the AMD Support and Game forum.
There are currently 3 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.