Topic Title: I can't download AMD Catalyst driver from the site !!
Topic Summary: I can't download AMD Catalyst driver from the site !!
Created On: 09/23/2013 05:48 PM
Status: Post and Reply
Linear : Threading : Single : Branch
<< 1 2 Previous Last unread
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 09/25/2013 10:04 AM
User is offline View Users Profile Print this message

Author Icon
Kent@AMD
Grinding Levels

Posts: 127
Joined: 01/10/2013

WMudrock is on it there. We've seen reports come from Australia and the EU regarding this, but nothing in North/South America, which definitely points to certain DNS servers. Thankfully the direct link works, so if you need 13.9 WHQL for 5xxx-7xxx, the ati2 fileserver can be accessed directly at http://www2.ati.com/drivers/13-9_win7_win8_64_dd_ccc_whql.exe . At least it worked for a couple users who contacted us with that issue.



-------------------------
AMD Customer Care

The information presented in this document is for informational purposes only and may contain technical inaccuracies, omissions and typographical errors. Links to third party sites are for convenience only, and no endorsement is implied.
 09/25/2013 12:52 PM
User is offline View Users Profile Print this message

Author Icon
Talo
Peon

Posts: 14
Joined: 09/24/2013

I hope that they don't take that long.

What if someone uploads the autondetect & install app to mediafire. Are we going to have the same issue if we try to download the driverd through that app?

I'M going to read those in the weekend

Thanks for your help! 

 09/25/2013 01:12 PM
User is offline View Users Profile Print this message

Author Icon
Shpati
Peon

Posts: 40
Joined: 10/01/2009

I have the same issue and I am in the US.



-------------------------
 09/25/2013 01:28 PM
User is offline View Users Profile Print this message

Author Icon
WMudrockJr
Overclocker

Posts: 705
Joined: 04/01/2013

Have you tried the link that Kent@AMD supplied?



-------------------------

AMD A10-5800K, XFX 7850 Ultra OC Edition 975MHz, 16GB RAM, Win 8.1 Pro 64 bit, MSI 7778 motherboard, 500W PSU, HP P7-1235, CCC 13.12 WHQL

 09/25/2013 01:46 PM
User is offline View Users Profile Print this message

Author Icon
Talo
Peon

Posts: 14
Joined: 09/24/2013

Yes, that one works for me. But unfortunately, my card is 4850, and that link is for for 5xxx-7xxx 

 09/25/2013 02:09 PM
User is offline View Users Profile Print this message

Author Icon
Talo
Peon

Posts: 14
Joined: 09/24/2013

I think I found another link that works, trying to acces from "Top downloads"

http://support.amd.com/us/kbarticles/Pages/catalystlegacywin8.aspx

This is it right? It says it is both for Windows 8 32 and 64 bits... 

 09/25/2013 02:43 PM
User is offline View Users Profile Print this message

Author Icon
feline1
Peon

Posts: 2
Joined: 09/24/2013

I am in the UK (ISP = TalkTalk) and the links were down for me.

 

However, I cunningly still managed to download the driver by first downloading the little tool that scans your hardware and automatically retrieves the right driver, rather than using the web interface to navigate to the download link

 09/25/2013 03:08 PM
User is offline View Users Profile Print this message

Author Icon
Shpati
Peon

Posts: 40
Joined: 10/01/2009

I tried downloading the mobility win 7 5xxx driver, but it gave me that error.

 

when i tried a different desktop driver it worked.

 

someone told me that ati took off some drivers off their site due to backlight issues, so i think that may have been the problem. 



-------------------------
 09/25/2013 10:04 PM
User is offline View Users Profile Print this message

Author Icon
Haytham
Peon

Posts: 3
Joined: 09/23/2013

Hi Guys

I tried this DNS In my Windows

180.131.144.144
180.131.145.145

And The Page work fine now with me and I downloaded the Driver 13-9_win7_win8_64_dd_ccc_whql

You can try It and let me know If It work like me or not but after you add the DNS In windows It's better to restart your PC and wait 5 min and test

 

 09/26/2013 06:04 PM
User is offline View Users Profile Print this message

Author Icon
Shpati
Peon

Posts: 40
Joined: 10/01/2009

I'll be home in a little bit and give an update.

But at school, I can go to the Mobility 5xxx drivers with no issues.

 

But at home, it gives me that error. Although I was able to find reach the and download the ATI desktop 4xxx HD with no problem. 

Maybe they just fixed it, so I will check at home



-------------------------
 09/26/2013 06:48 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4851
Joined: 12/27/2008

I also see this message if I try to open the linux driver download page from amd.com. Windows driver pages work for me. Strange.

I'm in Eastern Europe and tried 2 very different ISPs in 2 different cities. Yeah, 2 computers as well, those in my sig.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

 09/26/2013 09:50 PM
User is offline View Users Profile Print this message

Author Icon
Shpati
Peon

Posts: 40
Joined: 10/01/2009

I'm getting this page when I sometimes open CCC. Sometimes I get the home tab/page but sometimes I get that "please try again" error.



-------------------------
 09/26/2013 10:01 PM
User is offline View Users Profile Print this message

Author Icon
bigpoo02
Peon

Posts: 4
Joined: 09/26/2013

Im getting the please try again error to, its been like this for a few days now. I tried every different why to get the drivers and nothing is working. Any help yet from AMD?

Statistics
84350 users are registered to the AMD Support and Game forum.
There are currently 0 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.