Topic Title: Driver Installation Question
Topic Summary:
Created On: 10/14/2013 06:16 PM
Status: Post and Reply
Linear : Threading : Single : Branch
Search Topic Search Topic
Topic Tools Topic Tools
View similar topics View similar topics
View topic in raw text format. Print this topic.
 10/14/2013 06:16 PM
User is offline View Users Profile Print this message

Author Icon
Steavis
Peon

Posts: 2
Joined: 10/07/2013

I'll openly admit from the start that my knowledge is limited in many respects, so if I am missing any "necessary" information, you'll have to tell me what and how to find it.

My issue is that I cannot for the life of me update my drivers. I have an iMac which I run both the OSX Moutain Lion (kept up to date at all times) and then I also have a 64-bit version of Windows 8 which I load up via Boot Camp (it's a WinMac.) Almost everything works fine but neither side will apply updated drivers for my card, which if I am not mistaken is an AMD HD 6750. 

The FAQ said that OSX updates them automatically when you do a software update and so I ran a software update and updated drivers were not included in the mix. I've also tried downloading the appropriate files from the AMD website while on my Windows side and each time I run the catalyst installer program it will fail to download, and any attempt to "update driver" from the control panel ends with a message about how my card is up to date, though the numbers are smaller than the most recent shown on the website (again, I don't remember these numbers, I just know that mine is smaller than the ones on the site.)

Any ideas?

I apologize for my lack of technical intelligence, it's never been my strong suit by any means.

 10/14/2013 06:33 PM
User is offline View Users Profile Print this message

Author Icon
Eydee
Ninja Zombie Killer

Posts: 4905
Joined: 12/27/2008

Unfortunately macs have OEM cards, regular driver won't work, not even under bootcamp. You'll have to talk to Apple and get your drivers from them.



-------------------------

CPU: AMD Phenom II X4 810 @ 3120MHz | RAM: Kingmax 2x2GB DDR2 800 @ 833MHz| MoBo: MSI K9A2 CF v1.0 (BIOS: 1.D)| GPU: Asus HD 6850 1024MB (DirectCu) @ 835/1135MHz | Display: L24FHD | PSU: PC Power & Cooling Silencer 750 Quad | OS: MS Windows 3.11 Pro x64

Statistics
88754 users are registered to the AMD Support and Game forum.
There are currently 2 users logged in.

FuseTalk Hosting Executive Plan v3.2 - © 1999-2014 FuseTalk Inc. All rights reserved.